summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b23a55a83593
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-sil-sophia-nubian
+ pkgdesc = Unicode font with coverage of Coptic Unicode character set for Nubian languages
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://software.sil.org/sophianubian
+ arch = any
+ license = custom:OFL
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://software.sil.org/downloads/r/sophia-nubian/SophiaNubian-1.0.zip
+ sha256sums = d1c4748b712cd43f3fd30f8a6a34ee362d102912e900c82f04380206ae7b9b5f
+
+pkgname = ttf-sil-sophia-nubian
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39313fd53e96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+_pkgname=sophia-nubian
+pkgname=ttf-sil-$_pkgname
+_fname=SophiaNubian
+pkgver=1.0
+pkgrel=1
+pkgdesc='Unicode font with coverage of Coptic Unicode character set for Nubian languages'
+arch=('any')
+url="https://software.sil.org/${_pkgname/-}"
+license=('custom:OFL')
+depends=('fontconfig' 'xorg-font-utils')
+source=("http://software.sil.org/downloads/r/$_pkgname/$_fname-$pkgver.zip")
+sha256sums=('d1c4748b712cd43f3fd30f8a6a34ee362d102912e900c82f04380206ae7b9b5f')
+
+package() {
+ cd "$_fname"
+ find -type f -iname "SN*.ttf" -execdir \
+ install -Dm644 {} -t "$pkgdir/usr/share/fonts/TTF" \;
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}