summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61f3cb6b0a7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-whatsapp-emoji
+ pkgdesc = TrueType WhatsApp emojis
+ pkgver = 2.21.23.23
+ pkgrel = 1
+ url = https://github.com/dmlls/whatsapp-emoji-linux
+ arch = any
+ license = Apache
+ provides = emoji-font
+ conflicts = noto-fonts-emoji
+ conflicts = ttf-symbola
+ conflicts = ttf-joypixels
+ conflicts = ttf-twemoji-color
+ conflicts = ttf-apple-emoji
+ source = WhatsAppEmoji.ttf::https://github.com/dmlls/whatsapp-emoji-linux/releases/download/latest/WhatsAppEmoji.ttf
+ sha256sums = 9e7c230e16a04a2bc2804ec431f3c05d3d2c202b89103851b122651d0ee50d96
+
+pkgname = ttf-whatsapp-emoji
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83a1c37b4471
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Diego Miguel <hello@diegomiguel.me>
+
+pkgname='ttf-whatsapp-emoji'
+pkgver='2.21.23.23'
+pkgrel=1
+pkgdesc='TrueType WhatsApp emojis'
+arch=('any')
+url='https://github.com/dmlls/whatsapp-emoji-linux'
+license=('Apache')
+depends=()
+provides=(emoji-font)
+conflicts=(
+ 'noto-fonts-emoji'
+ 'ttf-symbola'
+ 'ttf-joypixels'
+ 'ttf-twemoji-color'
+ 'ttf-apple-emoji'
+)
+
+source=(
+ WhatsAppEmoji.ttf::$url/releases/download/latest/WhatsAppEmoji.ttf
+)
+
+sha256sums=('9e7c230e16a04a2bc2804ec431f3c05d3d2c202b89103851b122651d0ee50d96')
+
+package() {
+ install -dm 755 "${pkgdir}/usr/share/fonts/TTF"
+ install -m 644 WhatsAppEmoji.ttf "${pkgdir}/usr/share/fonts/TTF/"
+}
+