summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--ttf-xo-oriel-condensed.install15
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81c3cc90668a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ttf-xo-oriel-condensed
+ pkgdesc = XO Oriel Condensed font created considering trends of modern typography from «Новые облачные технологии»
+ pkgver = 1.00
+ pkgrel = 1
+ url = https://fonts.myoffice.ru
+ install = ttf-xo-oriel-condensed.install
+ arch = any
+ license = custom: XO FONTS Open License
+ makedepends = dos2unix
+ makedepends = glibc
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = XO_Oriel_Condensed-1.00.zip::http://fonts.myoffice.ru/wp-content/themes/template/fonts_page/files/XO_Oriel_Condensed.zip
+ sha256sums = 671c76493faad648e799b88686652d5f8adeec7c8fbe379dc4b49d8749c70243
+
+pkgname = ttf-xo-oriel-condensed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..205f8dcf7f23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Roman Mikhayloff <rimf@inbox.ru>
+
+pkgname=ttf-xo-oriel-condensed
+pkgver=1.00 # The fake version, the original is unversioned.
+pkgrel=1
+pkgdesc="XO Oriel Condensed font created considering trends of modern typography from «Новые облачные технологии»"
+arch=('any')
+url="https://fonts.myoffice.ru"
+license=('custom: XO FONTS Open License')
+depends=('fontconfig' 'xorg-font-utils')
+makedepends=('dos2unix' 'glibc')
+source=("XO_Oriel_Condensed-${pkgver}.zip::http://fonts.myoffice.ru/wp-content/themes/template/fonts_page/files/XO_Oriel_Condensed.zip")
+sha256sums=('671c76493faad648e799b88686652d5f8adeec7c8fbe379dc4b49d8749c70243')
+install=${pkgname}.install
+
+prepare() {
+ iconv -f cp1251 -t utf8 -o LICENSE XO_Fonts_License.txt
+ dos2unix LICENSE
+}
+
+package() {
+ install -dm755 "${pkgdir}"/usr/share/fonts/TTF
+
+ cd "${srcdir}"
+ install -m644 *.ttf "${pkgdir}"/usr/share/fonts/TTF/
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/ttf-xo-oriel-condensed.install b/ttf-xo-oriel-condensed.install
new file mode 100644
index 000000000000..724145fffa8a
--- /dev/null
+++ b/ttf-xo-oriel-condensed.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ fc-cache -s > /dev/null
+ mkfontscale /usr/share/fonts/TTF
+ mkfontdir /usr/share/fonts/TTF
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}