summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
-rw-r--r--cstddef.patch11
3 files changed, 20 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e42970dfb78..6935367c76ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = ttf2eot
pkgdesc = Utility to convert TTF files to EOT
- pkgver = 0.0.2
- pkgrel = 2
- url = http://code.google.com/p/ttf2eot/
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/wget/ttf2eot
arch = i686
arch = x86_64
license = GPL
- source = http://ttf2eot.googlecode.com/files/ttf2eot-0.0.2-2.tar.gz
- source = cstddef.patch
- md5sums = 97c9ceb0ded362bf2e6dd3a3a9360f8d
- md5sums = 2f4d5c3e2ff22f52da21546819211d3a
+ source = https://github.com/wget/ttf2eot/archive/v0.0.3.tar.gz
+ sha512sums = d926d856bd3bf363919c0b0bf382527fc58d4cd7291d27b4ed44e1feabcc2353c4aa0ffb4376f0c6890a8d9c35d3c4db4357ce94af6dcf64223168731c9fc263
pkgname = ttf2eot
diff --git a/PKGBUILD b/PKGBUILD
index 1218b0965cf5..56900dfb353e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Original submitter: wooptoo
-# Maintainer: rws <elisp dot vim at google mail> (@xd1le on twitter)
+# Maintainer: William Gathoye <william at gathoye dot be>
pkgname=ttf2eot
-pkgver=0.0.2
-pkgrel=2
+pkgver=0.0.3
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Utility to convert TTF files to EOT"
-url="http://code.google.com/p/ttf2eot/"
+url="https://github.com/wget/ttf2eot"
license=('GPL')
depends=()
makedepends=()
-source=(http://$pkgname.googlecode.com/files/$pkgname-$pkgver-$pkgrel.tar.gz
- cstddef.patch)
-md5sums=(97c9ceb0ded362bf2e6dd3a3a9360f8d
- 2f4d5c3e2ff22f52da21546819211d3a)
+source=(
+ https://github.com/wget/$pkgname/archive/v$pkgver.tar.gz
+)
+sha512sums=(
+ d926d856bd3bf363919c0b0bf382527fc58d4cd7291d27b4ed44e1feabcc2353c4aa0ffb4376f0c6890a8d9c35d3c4db4357ce94af6dcf64223168731c9fc263
+)
build() {
- patch -Np0 -i $srcdir/cstddef.patch || return 1
- cd $srcdir/$pkgname-$pkgver-$pkgrel
- make || return 1
+ cd "$srcdir/$pkgname-$pkgver"
+ make
}
package() {
- mkdir -p $pkgdir/usr/bin
- cp $srcdir/$pkgname-$pkgver-$pkgrel/$pkgname $pkgdir/usr/bin
+ cd "$srcdir/$pkgname-$pkgver"
+ install -dm755 "$pkgdir/usr/bin/"
+ cp ttf2eot "$pkgdir/usr/bin/"
}
diff --git a/cstddef.patch b/cstddef.patch
deleted file mode 100644
index 94ed11aff15c..000000000000
--- a/cstddef.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ttf2eot-0.0.2-2/OpenTypeUtilities.h 2009-04-30 12:18:46.000000000 +0300
-+++ new/OpenTypeUtilities.h 2011-12-13 14:03:02.697670526 +0200
-@@ -28,6 +28,8 @@
- #ifndef OpenTypeUtilities_h
- #define OpenTypeUtilities_h
-
-+#include <cstddef>
-+
- using std::vector;
-
- bool getEOTHeader(unsigned char * fontData, size_t fontSize, vector<uint8_t>& eotHeader, size_t& overlayDst, size_t& overlaySrc, size_t& overlayLength);