summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c9d61be250d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ttk-themes
+ pkgdesc = A group of themes for the ttk extenstions for Tkinter gathered together by RedFantom and created by various authors.
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = https://github.com/RedFantom/ttkthemes
+ arch = x86_64
+ arch = i686
+ license = GPLv3
+ depends = tcl
+ depends = tk
+ optdepends = ttk-theme-chooser
+ source = https://github.com/RedFantom/ttkthemes/archive/2.2.0.tar.gz
+ md5sums = 9cbf8afe3dce3d83f5ee32022856d6aa
+
+pkgname = ttk-themes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a5a1638c354
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=ttk-themes
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="A group of themes for the ttk extenstions for Tkinter gathered together by RedFantom and created by various authors."
+url="https://github.com/RedFantom/ttkthemes"
+arch=('x86_64' 'i686')
+license=('GPLv3')
+depends=('tcl' 'tk')
+optdepends=('ttk-theme-chooser')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://github.com/RedFantom/ttkthemes/archive/2.2.0.tar.gz")
+
+md5sums=('9cbf8afe3dce3d83f5ee32022856d6aa')
+
+build() {
+ tar xzf ${pkgver}.tar.gz
+ }
+
+package() {
+ cd ttkthemes-${pkgver}
+ mkdir -p ${pkgdir}/usr/lib/ttkthemes
+ cp -r ttkthemes/themes/* ${pkgdir}/usr/lib/ttkthemes/
+ }