summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 25 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5395c37b03f5..f737c05963c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = tttermwidget
- pkgdesc = A terminal widget for Qt
- pkgver = 0.6.0
+ pkgdesc = Terminal widget used by theTerminal
+ pkgver = 2.0
pkgrel = 2
- url = https://github.com/vicr123/tttermwidget
- arch = i686
+ url = https://github.com/theCheeseboard/tttermwidget
arch = x86_64
+ arch = aarch64
license = GPL2
+ makedepends = git
+ makedepends = qt6-tools
makedepends = cmake
- depends = qt5-base
+ makedepends = clang
depends = libsm
depends = libxkbcommon-x11
- source = tttermwidget-0.6.0::git+https://github.com/vicr123/tttermwidget
- md5sums = SKIP
+ depends = libutf8proc
+ depends = libcontemporary
+ depends = qt6-5compat
+ source = tttermwidget::https://github.com/theCheeseboard/tttermwidget/archive/v2.0.tar.gz
+ sha256sums = 41817db1c22a539e6e1a95562d017b624ace0d130327b6165c2f3433afaf6d94
pkgname = tttermwidget
-
diff --git a/PKGBUILD b/PKGBUILD
index 83e528acc608..6be764457835 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,23 @@
-# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=tttermwidget
-pkgver=0.6.0
+pkgver=2.0
pkgrel=2
-pkgdesc="A terminal widget for Qt"
-arch=("i686" "x86_64")
-url="https://github.com/vicr123/tttermwidget"
+pkgdesc="Terminal widget used by theTerminal"
+arch=("x86_64" "aarch64")
+url="https://github.com/theCheeseboard/tttermwidget"
license=("GPL2")
-depends=("qt5-base" "libsm" "libxkbcommon-x11")
-makedepends=("cmake")
-source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/tttermwidget')
-md5sums=("SKIP")
+depends=("libsm" "libxkbcommon-x11" "libutf8proc" "libcontemporary" "qt6-5compat")
+makedepends=('git' 'qt6-tools' 'cmake' 'clang')
+source=("tttermwidget"::"https://github.com/theCheeseboard/tttermwidget/archive/v$pkgver.tar.gz")
+sha256sums=("41817db1c22a539e6e1a95562d017b624ace0d130327b6165c2f3433afaf6d94")
build() {
- mkdir -p build
- cd build
- cmake "$srcdir/$pkgname-$pkgver" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
- -DBUILD_DESIGNER_PLUGIN=0 \
- -DUSE_QT5=true
- make
+ cmake -B build -S "$pkgname-$pkgver" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install "build"
}