summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ebd011f9643
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ttv
+ pkgdesc = A command line tool for splitting files into test, train, and validation sets.
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/sd2k/ttv
+ arch = x86_64
+ license = CUSTOM
+ makedepends = rust
+ source = ttv-0.2.1.tar.gz::https://github.com/sd2k/ttv/archive/v0.2.1.tar.gz
+ sha256sums = SKIP
+
+pkgname = ttv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d2630e5711f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Attenuation <ouyangjun1999@gmail.com>
+pkgname=ttv
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='A command line tool for splitting files into test, train, and validation sets. '
+arch=('x86_64')
+url='https://github.com/sd2k/ttv'
+license=('CUSTOM')
+makedepends=('rust')
+depends=()
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
+} \ No newline at end of file