summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32666966f9bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = ttyecho-git
+ pkgdesc = Send commands or data to other terminals.
+ pkgver = r2.beb3ecc
+ pkgrel = 1
+ url = https://github.com/osospeed/ttyecho.git
+ arch = any
+ makedepends = git
+ source = ttyecho-git::git+https://github.com/osospeed/ttyecho.git
+ sha1sums = SKIP
+
+pkgname = ttyecho-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d37293c13d99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: OSO <osospeed@hotmail.com>
+pkgname=ttyecho-git
+pkgver=r2.beb3ecc
+pkgrel=1
+pkgdesc="Send commands or data to other terminals."
+arch=('any')
+url="https://github.com/osospeed/ttyecho.git"
+makedepends=('git')
+sha1sums=('SKIP')
+
+source=("$pkgname"::"git+${url}")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="${pkgdir}/usr/bin/" install
+}