summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7dd526313544..c1b642d489da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = tuhi-git
pkgdesc = DBus daemon to access Wacom SmartPad devices
- pkgver = 20190608
+ pkgver = 20191104
pkgrel = 1
url = https://github.com/tuhiproject/tuhi
arch = any
license = GPL2
makedepends = git
makedepends = python-setuptools
+ makedepends = meson
+ makedepends = ninja
depends = python
depends = python-svgwrite
depends = python-xdg
diff --git a/PKGBUILD b/PKGBUILD
index 21ddc928acd8..4ca54e1df1b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,22 @@
# Maintainer: Christian Muehlhaeuser <muesli at gmail dot com>
pkgname=tuhi-git
-pkgver=20190608
+pkgver=20191104
pkgrel=1
pkgdesc="DBus daemon to access Wacom SmartPad devices"
arch=('any')
depends=('python' 'python-svgwrite' 'python-xdg')
-makedepends=('git' 'python-setuptools')
+makedepends=('git' 'python-setuptools' 'meson' 'ninja')
url="https://github.com/tuhiproject/tuhi"
license=('GPL2')
source=(git+https://github.com/tuhiproject/tuhi)
sha256sums=('SKIP')
+prepare() {
+ cd ${pkgname%-git}
+ sed -i '/meson_version:/s/0.50.0/0.51.0/' meson.build
+}
+
pkgver() {
cd ${pkgname%-git}
git log -1 --format="%cd" --date=short | sed "s|-||g"
@@ -20,15 +25,12 @@ pkgver() {
build() {
cd ${pkgname%-git}
- python setup.py build
+ meson builddir --prefix=/usr
+ cd builddir
+ ninja
}
package() {
- cd ${pkgname%-git}
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm755 tools/tuhi-live.py "${pkgdir}/usr/bin/tuhi-live.py"
- install -Dm755 tools/tuhi-kete-sandboxed.py "${pkgdir}/usr/bin/tuhi-kete-sandboxed.py"
- install -Dm755 tools/kete.py "${pkgdir}/usr/bin/kete.py"
- install -Dm755 tools/tuhi-live.py "${pkgdir}/usr/bin/tuhi-live.py"
- install -Dm644 README.md "${pkgdir}/usr/share/doc/tuhi/README.md"
+ cd ${pkgname%-git}/builddir
+ DESTDIR="${pkgdir}" ninja install
}