summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD7
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3112e8514e3..3250c8411c47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = tunefish4-git
pkgdesc = An additive wavetable-based synthesizer VST plugin (git version)
pkgver = 4.3.0.r107.7e48ce8
- pkgrel = 1
+ pkgrel = 2
url = https://www.tunefish-synth.com/
arch = x86_64
groups = vst-plugins
license = GPL3
+ makedepends = alsa-lib
+ makedepends = curl
+ makedepends = freetype2
makedepends = git
makedepends = vst2sdk
- depends = webkit2gtk
+ depends = glibc
+ depends = gcc-libs
provides = tunefish4
conflicts = tunefish4
conflicts = tunefish4-vst-bin
@@ -16,3 +20,8 @@ pkgbase = tunefish4-git
sha256sums = SKIP
pkgname = tunefish4-git
+ depends = glibc
+ depends = gcc-libs
+ depends = libasound.so
+ depends = libcurl.so
+ depends = libfreetype.so
diff --git a/PKGBUILD b/PKGBUILD
index 7224a1389882..5aeef260ebca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
_pkgname=tunefish4
pkgname="${_pkgname}-git"
pkgver=4.3.0.r107.7e48ce8
-pkgrel=1
+pkgrel=2
pkgdesc='An additive wavetable-based synthesizer VST plugin (git version)'
arch=(x86_64)
url="https://www.tunefish-synth.com/"
# See https://github.com/paynebc/tunefish/blob/master/COPYING
license=(GPL3)
groups=(vst-plugins)
-depends=(webkit2gtk)
-makedepends=(git vst2sdk)
+depends=(glibc gcc-libs)
+makedepends=(alsa-lib curl freetype2 git vst2sdk)
provides=($_pkgname)
conflicts=($_pkgname "${_pkgname}-vst-bin")
source=("$_pkgname::git+https://github.com/paynebc/tunefish.git")
@@ -33,6 +33,7 @@ build() {
}
package() {
+ depends+=(libasound.so libcurl.so libfreetype.so)
cd $_pkgname
install -Dm755 src/tunefish4/Builds/LinuxMakefile/build/Tunefish4.so \
-t "$pkgdir"/usr/lib/vst