summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e410e19e456c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = tunsafe-git
+ pkgdesc = High performance and secure VPN client that uses the WireGuard protocol
+ pkgver = r9.ge116360
+ pkgrel = 1
+ url = https://tunsafe.com/
+ arch = i686
+ arch = x86_64
+ license = AGPL
+ license = BSD
+ license = custom: OpenSSL
+ makedepends = git
+ depends = gcc-libs
+ provides = tunsafe
+ conflicts = tunsafe
+ source = git+https://github.com/TunSafe/TunSafe.git
+ sha256sums = SKIP
+
+pkgname = tunsafe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7542dcf6796
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=tunsafe-git
+pkgver=r9.ge116360
+pkgrel=1
+pkgdesc="High performance and secure VPN client that uses the WireGuard protocol"
+arch=('i686' 'x86_64')
+url="https://tunsafe.com/"
+license=('AGPL' 'BSD' 'custom: OpenSSL')
+depends=('gcc-libs')
+makedepends=('git')
+provides=('tunsafe')
+conflicts=('tunsafe')
+source=("git+https://github.com/TunSafe/TunSafe.git")
+sha256sums=('SKIP')
+
+
+prepare() {
+ cd "TunSafe"
+
+ sed -i "s/clang++-6.0/g++ $CXXFLAGS/;s/-lrt/-lrt $LDFLAGS/" "build_linux.sh"
+}
+
+pkgver() {
+ cd "TunSafe"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "TunSafe"
+
+ ./build_linux.sh
+}
+
+package() {
+ cd "TunSafe"
+
+ install -Dm755 "tunsafe" "$pkgdir/usr/bin/tunsafe"
+ install -Dm644 "LICENSE.AGPL.TXT" "$pkgdir/usr/share/licenses/tunsafe/LICENSE.AGPL.TXT"
+}