summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
-rw-r--r--dkms.conf.in7
-rw-r--r--tuxedo-wmi-dkms.install20
4 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a5867dfbe2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = tuxedo-wmi-dkms
+ pkgdesc = A reverse engineering driver for the Clevo P150EM/P170EM/P150SM/P157SM/P170SM/P177SM backlight keyboard, by Christoph Jaeger (DKMS version)
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = http://www.linux-onlineshop.de/forum/index.php?page=Thread&threadID=26&s=82130b57e71bd5b6ea569abc1424025c6f8d412d
+ install = tuxedo-wmi-dkms.install
+ arch = any
+ license = GPL
+ depends = dkms
+ depends = linux-headers
+ provides = tuxedo-wmi
+ conflicts = clevo_wmi-git
+ conflicts = clevo-wmi
+ conflicts = clevo-wmi
+ conflicts = clevo-wmi-dkms
+ conflicts = tuxedo-wmi
+ replaces = clevo-wmi-dkms
+ source = tuxedo-wmi-1.5.1.src.tar.gz::http://www.linux-onlineshop.de/forum/index.php?page=Attachment&attachmentID=424&h=3df4c21145314ceaeadd7986662b2a5b01d1094f&s=5196669c65535d86e616f839936c42a5166a40a0
+ source = dkms.conf.in
+ md5sums = c5bf0f815f394baf4fabe2c78d9483cc
+ md5sums = 75fa1f51d5b4c15edcdfb8d60dd6ae54
+
+pkgname = tuxedo-wmi-dkms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f053a462158f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Author: Christoph Jaeger <christophjaeger@linux.com>
+# Maintainer: Marc Rozanc <marc@rozanc.fr>
+
+_modname="tuxedo-wmi"
+pkgname="${_modname}-dkms"
+pkgver="1.5.1"
+pkgrel=1
+pkgdesc='A reverse engineering driver for the Clevo P150EM/P170EM/P150SM/P157SM/P170SM/P177SM backlight keyboard, by Christoph Jaeger (DKMS version)'
+arch=('any')
+license=('GPL')
+url='http://www.linux-onlineshop.de/forum/index.php?page=Thread&threadID=26&s=82130b57e71bd5b6ea569abc1424025c6f8d412d'
+depends=('dkms' 'linux-headers')
+provides=("tuxedo-wmi")
+replaces=("clevo-wmi-dkms")
+conflicts=("clevo_wmi-git" "clevo-wmi" "clevo-wmi" "clevo-wmi-dkms" "tuxedo-wmi")
+source=("tuxedo-wmi-${pkgver}.src.tar.gz::http://www.linux-onlineshop.de/forum/index.php?page=Attachment&attachmentID=424&h=3df4c21145314ceaeadd7986662b2a5b01d1094f&s=5196669c65535d86e616f839936c42a5166a40a0"
+ "dkms.conf.in")
+md5sums=('c5bf0f815f394baf4fabe2c78d9483cc'
+ '75fa1f51d5b4c15edcdfb8d60dd6ae54')
+install='tuxedo-wmi-dkms.install'
+
+
+build() {
+ cd "${srcdir}/tuxedo-wmi-${pkgver}/src"
+ make
+}
+
+package() {
+ cd "${srcdir}/tuxedo-wmi-${pkgver}/src"
+
+ install -dm755 "${pkgdir}/usr/src/${_modname}-${pkgver}/"
+ for i in "${srcdir}/${_modname}-${pkgver}/src/"{Makefile,tuxedo-wmi.c}; do
+ install -D -m644 "${i}" "${pkgdir}/usr/src/${_modname}-${pkgver}/"
+ done
+ sed "s/#MODULE_VERSION#/${pkgver}/" "${srcdir}/dkms.conf.in" > "${pkgdir}/usr/src/${_modname}-${pkgver}/dkms.conf"
+}
+
diff --git a/dkms.conf.in b/dkms.conf.in
new file mode 100644
index 000000000000..6130c36ca27e
--- /dev/null
+++ b/dkms.conf.in
@@ -0,0 +1,7 @@
+PACKAGE_NAME="tuxedo-wmi"
+PACKAGE_VERSION="#MODULE_VERSION#"
+MAKE[0]="make KVERSION=$kernelver"
+CLEAN="make clean"
+BUILT_MODULE_NAME[0]="tuxedo-wmi"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/input/keyboard"
+AUTOINSTALL="yes"
diff --git a/tuxedo-wmi-dkms.install b/tuxedo-wmi-dkms.install
new file mode 100644
index 000000000000..9cee95462e8a
--- /dev/null
+++ b/tuxedo-wmi-dkms.install
@@ -0,0 +1,20 @@
+post_install() {
+ dkms install -m tuxedo-wmi -v ${1%%-*}
+}
+
+pre_upgrade() {
+ local curver=${2%%-*}
+ # $2 is unset due to a bug. See, https://bugs.archlinux.org/task/32278
+ # Query current version using pacman as fallback
+ [ -n "$curver" ] || curver=$(pacman -Q tuxedo-wmi-dkms | cut -d' ' -f2)
+ pre_remove $curver
+}
+
+post_upgrade() {
+ post_install ${1%%-*}
+}
+
+pre_remove() {
+ dkms remove -m tuxedo-wmi -v ${1%%-*} --all
+}
+