summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
-rw-r--r--tuxguitar.desktop13
-rw-r--r--tuxguitar.xml19
4 files changed, 20 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfac745a0cff..ed9d0610c0dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tuxguitar
pkgdesc = multitrack guitar tablature editor and player
pkgver = 1.4
- pkgrel = 2
+ pkgrel = 3
url = http://sourceforge.net/projects/tuxguitar
arch = x86_64
license = LGPL
@@ -10,7 +10,7 @@ pkgbase = tuxguitar
makedepends = apache-ant
makedepends = jack
makedepends = fluidsynth
- makedepends = jdk8-openjdk
+ makedepends = java-environment>=8
makedepends = maven
depends = java-runtime>=8
depends = alsa-lib
@@ -18,12 +18,8 @@ pkgbase = tuxguitar
depends = libxtst
optdepends = fluidsynth
source = tuxguitar-src-1.4.tar.gz::http://downloads.sourceforge.net/project/tuxguitar/TuxGuitar/TuxGuitar-1.4/tuxguitar-1.4-src.tar.gz
- source = tuxguitar.desktop
- source = tuxguitar.xml
source = nogcj.patch
sha256sums = ac72690bc1c20919dd66df46f757c6890be4c54b38f2a3b59a0265c777392210
- sha256sums = 6a6c2c64f75f7402b6913e493b847f6b6d9d789bad7ab3ec023f61784d38bbfa
- sha256sums = d5b79049776c39e8c58bfa5b9748678ed2ed376e7c4cc1e837de5666f18a8e56
sha256sums = bda4bc1b864ecfa27392a145854ee3b5ab20876c2d2bc38bbf85f92ce97fe2bc
pkgname = tuxguitar
diff --git a/PKGBUILD b/PKGBUILD
index df2cf84651ad..86f37d70efd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Alexandre Moine <alexandre@moine.me>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: |AhIoRoS| < ahioros@gmail.com >
pkgname=tuxguitar
pkgver=1.4
-pkgrel=2
+pkgrel=3
pkgdesc="multitrack guitar tablature editor and player"
arch=('x86_64')
url="http://sourceforge.net/projects/tuxguitar"
license=('LGPL')
depends=('java-runtime>=8' 'alsa-lib' 'gtk2' 'libxtst')
-makedepends=('unzip' 'zip' 'apache-ant' 'jack' 'fluidsynth' 'jdk8-openjdk' 'maven')
+makedepends=('unzip' 'zip' 'apache-ant' 'jack' 'fluidsynth' 'java-environment>=8' 'maven')
optdepends=('fluidsynth')
source=(tuxguitar-src-$pkgver.tar.gz::http://downloads.sourceforge.net/project/tuxguitar/TuxGuitar/TuxGuitar-$pkgver/tuxguitar-$pkgver-src.tar.gz
- tuxguitar.desktop tuxguitar.xml nogcj.patch)
+ nogcj.patch)
sha256sums=('ac72690bc1c20919dd66df46f757c6890be4c54b38f2a3b59a0265c777392210'
- '6a6c2c64f75f7402b6913e493b847f6b6d9d789bad7ab3ec023f61784d38bbfa'
- 'd5b79049776c39e8c58bfa5b9748678ed2ed376e7c4cc1e837de5666f18a8e56'
'bda4bc1b864ecfa27392a145854ee3b5ab20876c2d2bc38bbf85f92ce97fe2bc')
case $CARCH in
@@ -27,11 +26,18 @@ esac
prepare() {
cd tuxguitar-$pkgver-src
patch -Np1 -i ../nogcj.patch
+
+ # For jdk9
+ for _i in `find . -name pom.xml -print`; do
+ sed -i 's|<source>1.5</source>|<source>1.6</source>|g' $_i
+ sed -i 's|<target>1.5</target>|<target>1.6</target>|g' $_i
+ done
+
}
build() {
export MAVEN_OPTS="$MAVEN_OPTS -Duser.home=$srcdir"
- export JAVA_HOME="/usr/lib/jvm/java-8-openjdk"
+ export JAVA_HOME="/usr/lib/jvm/"`archlinux-java get`
cd tuxguitar-$pkgver-src
for _i in . TuxGuitar-{lib,gm-utils} \
@@ -61,14 +67,15 @@ package() {
done
done
- # desktop files
- cd ..
+ # Misc
+ install -Dm644 misc/tuxguitar.xml "$pkgdir"/usr/share/mime/packages/tuxguitar.xml
+ install -Dm644 misc/tuxguitar.desktop "$pkgdir"/usr/share/applications/tuxguitar.desktop
+
+ # Launcher
install -D /dev/stdin "$pkgdir"/usr/bin/tuxguitar <<EOF
#!/bin/sh -e
export SWT_GTK3=0
cd /usr/share/tuxguitar
exec ./tuxguitar.sh -Dorg.eclipse.swt.internal.gtk.cairoGraphics=false "\$@"
EOF
- install -Dm644 tuxguitar.xml "$pkgdir"/usr/share/mime/packages/tuxguitar.xml
- install -Dm644 tuxguitar.desktop "$pkgdir"/usr/share/applications/tuxguitar.desktop
}
diff --git a/tuxguitar.desktop b/tuxguitar.desktop
deleted file mode 100644
index 4bb6a96584a9..000000000000
--- a/tuxguitar.desktop
+++ /dev/null
@@ -1,13 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=tuxguitar
-Comment=Edit, playback guitar tablatures
-Comment[fr]=Edite, joue des tablatures de guitare
-Comment[es]=Edita, reproduce tablaturas de guitarra
-Exec=tuxguitar %F
-Icon=tuxguitar
-Terminal=false
-Type=Application
-Categories=Application;AudioVideo;Audio;
-MimeType=audio/x-tuxguitar;audio/x-gtp;audio/x-ptb;
-#eof "$Id: tuxguitar.desktop,v 1.2 2008/09/15 07:54:28 sergej Exp $"
diff --git a/tuxguitar.xml b/tuxguitar.xml
deleted file mode 100644
index 4c85c8f4eec6..000000000000
--- a/tuxguitar.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
- <mime-type type="audio/x-tuxguitar">
- <comment>TuxGuitar file</comment>
- <glob pattern="*.tg"/>
- </mime-type>
- <mime-type type="audio/x-gtp">
- <comment>GuitarPro file</comment>
- <glob pattern="*.gtp"/>
- <glob pattern="*.gp3"/>
- <glob pattern="*.gp4"/>
- <glob pattern="*.gp5"/>
- <glob pattern="*.gpx"/>
- </mime-type>
- <mime-type type="audio/x-ptb">
- <comment>PowerTab file</comment>
- <glob pattern="*.ptb"/>
- </mime-type>
-</mime-info>