summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d760499c129..55cb25e3f06e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = tuxmath
pkgdesc = An arcade game that helps kids practice their math facts
pkgver = 2.0.3
- pkgrel = 1
+ pkgrel = 2
url = http://tux4kids.alioth.debian.org/tuxmath/
arch = i686
arch = x86_64
license = GPL
+ license = custom:OFL
license = custom
makedepends = make
- depends = t4k_common
+ depends = t4kcommon
options = !docs
- source = http://distro.ibiblio.org/slitaz/sources/packages/t/tuxmath_w_fonts-2.0.3.tar.gz
- sha1sums = 74510bc342d6cefb6dae101cfc8c1207f29d7db9
+ source = https://github.com/tux4kids/tuxmath/archive/upstream/2.0.3.tar.gz
+ sha256sums = ab91bd6df17eb9377e5608701030bd32110a3588933bf0e4c26b5697fb2a4698
pkgname = tuxmath
diff --git a/PKGBUILD b/PKGBUILD
index 8169f6a87c69..2239a8bad268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Tasos Latsas < tlatsas2000 at gmail dot com >
+# Maintainer: Alexandre Moine < nobrakal at cthugha dot org >
+# Contributor: Tasos Latsas < tlatsas2000 at gmail dot com >
# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
# Contributor: arjan <arjan@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
@@ -6,33 +7,38 @@
pkgname=tuxmath
pkgver=2.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="An arcade game that helps kids practice their math facts"
arch=('i686' 'x86_64')
url="http://tux4kids.alioth.debian.org/tuxmath/"
-license=('GPL' 'custom')
-depends=('t4k_common')
+license=('GPL' 'custom:OFL' 'custom')
+depends=('t4kcommon')
makedepends=('make')
options=('!docs')
-source=(http://distro.ibiblio.org/slitaz/sources/packages/t/${pkgname}_w_fonts-$pkgver.tar.gz)
-sha1sums=('74510bc342d6cefb6dae101cfc8c1207f29d7db9')
+source=(https://github.com/tux4kids/$pkgname/archive/upstream/$pkgver.tar.gz)
+sha256sums=('ab91bd6df17eb9377e5608701030bd32110a3588933bf0e4c26b5697fb2a4698')
build() {
- cd "$srcdir/${pkgname}_w_fonts-$pkgver"
+ cd "$srcdir/${pkgname}-upstream-$pkgver"
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/${pkgname}_w_fonts-$pkgver"
+ cd "$srcdir/${pkgname}-upstream-$pkgver"
make DESTDIR=$pkgdir install
# install .desktop file and icons
mkdir -p $pkgdir/usr/share/{applications,pixmaps}
- install -D -m644 tuxmath.desktop $pkgdir/usr/share/applications/tuxmath.desktop
- install -D -m644 data/images/icons/icon.png $pkgdir/usr/share/pixmaps/tuxmath.png
+ install -D -m644 tuxmath.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -D -m644 data/images/icons/icon.png $pkgdir/usr/share/pixmaps/$pkgname.png
+
+ # Install doc
+ mkdir -p $pkgdir/usr/share/doc/$pkgname
+ install -D -m644 doc/README \
+ $pkgdir/usr/share/doc/$pkgname/README
# install licenses
install -D -m644 doc/OFL \