summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fd837b5c0e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = tuxmath-git
+ pkgdesc = Common library for code shared by TuxType and TuxMath
+ pkgver = r989.63bfc8a
+ pkgrel = 1
+ url = http://tux4kids.alioth.debian.org/
+ arch = armv7h
+ arch = aarch64
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = gettext
+ makedepends = libtool
+ makedepends = make
+ depends = t4kcommon-git
+ options = !docs
+ source = git+https://github.com/tux4kids/tuxmath
+ sha256sums = SKIP
+
+pkgname = tuxmath-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc1ddb6bdbf0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Michael Taboada <michael@2mb.solutions>
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Contributor: Alexandre Moine < nobrakal at cthugha dot org >
+# Contributor: Tasos Latsas < tlatsas2000 at gmail dot com >
+# Contributor: Kyle < kyle at free 2 dot ml >
+
+pkgname=tuxmath-git
+_gitname=tuxmath
+pkgver=r989.63bfc8a
+
+
+pkgrel=1
+pkgdesc="Common library for code shared by TuxType and TuxMath"
+arch=('armv7h' 'aarch64' 'i686' 'x86_64')
+url="http://tux4kids.alioth.debian.org/"
+license=('GPL')
+#depends=('sdl_image' 'sdl_mixer' 'sdl_pango' 'sdl_net' 'libpng' 'librsvg' 'libxml2')
+depends=('t4kcommon-git')
+makedepends=('autoconf' 'automake' 'gettext' 'libtool' 'make')
+options=('!docs')
+#replace=('t4k_common')
+source=("git+https://github.com/tux4kids/tuxmath")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ # Use the tag of the last commit
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+#prepare() {
+# cd "$srcdir/$_gitname"
+# patch -Np2 -i "$srcdir/libpng15.patch"
+#}
+
+build() {
+ cd "$srcdir/$_gitname"
+ autoreconf -if .
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ make DESTDIR=$pkgdir install
+}
+