summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD27
-rw-r--r--freetype2.patch28
3 files changed, 15 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ba96d2c03a5..56cbebacef62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tuxpaint
pkgdesc = Drawing program designed for young children
- pkgver = 0.9.28
- pkgrel = 3
+ pkgver = 0.9.29
+ pkgrel = 1
url = https://tuxpaint.org/
arch = x86_64
license = GPL
@@ -21,9 +21,7 @@ pkgbase = tuxpaint
optdepends = tuxpaint-config: configuration manager
optdepends = python2: zh_tw font generator script
backup = etc/tuxpaint/tuxpaint.conf
- source = https://downloads.sourceforge.net/sourceforge/tuxpaint/tuxpaint-0.9.28-sdl2.tar.gz
- source = freetype2.patch
- sha256sums = 4f1ed9330feab324070b93630d79ced50ccc4816ab76750119f012b5d904709d
- sha256sums = SKIP
+ source = https://downloads.sourceforge.net/sourceforge/tuxpaint/tuxpaint-0.9.29.tar.gz
+ sha256sums = 575403c54c7243e5b269a71fc1aa0738e3937764787e2acf89686bd77c5ae6ca
pkgname = tuxpaint
diff --git a/PKGBUILD b/PKGBUILD
index 9c456b41549e..4de77ffc11d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,9 @@
# Contributor: Sergio Jovani Guzman <moret.sjg@gmail.com>
# Contributor: royrocks <royrocks13@gmail.com>
-_pkgtype=sdl2
pkgname=tuxpaint
-pkgver=0.9.28
-pkgrel=3
+pkgver=0.9.29
+pkgrel=1
pkgdesc='Drawing program designed for young children'
arch=('x86_64')
url='https://tuxpaint.org/'
@@ -18,38 +17,34 @@ makedepends=('gperf' 'setconf' 'imagemagick')
optdepends=('tuxpaint-stamps: more stamps'
'tuxpaint-config: configuration manager'
'python2: zh_tw font generator script')
-source=("https://downloads.sourceforge.net/sourceforge/tuxpaint/$pkgname-$pkgver-$_pkgtype.tar.gz" "freetype2.patch")
-sha256sums=('4f1ed9330feab324070b93630d79ced50ccc4816ab76750119f012b5d904709d' SKIP)
+source=("https://downloads.sourceforge.net/sourceforge/tuxpaint/$pkgname-$pkgver.tar.gz")
+sha256sums=('575403c54c7243e5b269a71fc1aa0738e3937764787e2acf89686bd77c5ae6ca')
prepare() {
- cd "$pkgname-$pkgver-$_pkgtype"
+ cd "$pkgname-$pkgver"
# python2 fix
for f in docs/outdated/zh_tw/mkTuxpaintIM.py fonts/locale/zh_tw_docs/maketuxfont.py; do
sed -i '0,/on/s//on2/' $f
done
- # desktop shortcut categories
- setconf src/tuxpaint.desktop Categories='Game;KidsGame;Graphics;RasterGraphics;'
-
- # fullscreen by default
- setconf -u src/tuxpaint.conf fullscreen=true
+ # native fullscreen by default
+ setconf -u src/tuxpaint.conf fullscreen=yes
+ setconf -u src/tuxpaint.conf native=yes
# location of bash completion files
setconf Makefile COMPLETIONDIR='$(DESTDIR)/usr/share/bash-completion/completions'
# no KDE4-related requirements at installation-time
setconf Makefile ARCH_INSTALL='install-man install-importscript install-bash-completion'
-
- patch -Np1 < "../freetype2.patch"
}
build() {
- make -C "$pkgname-$pkgver-$_pkgtype" PREFIX=/usr clean translations all -j1
+ make -C "$pkgname-$pkgver" PREFIX=/usr clean translations all -j1
}
package() {
- make -C "$pkgname-$pkgver-$_pkgtype" \
+ make -C "$pkgname-$pkgver" \
PREFIX=/usr \
GNOME_PREFIX=/usr \
X11_ICON_PREFIX="$pkgdir/usr/share/pixmaps" \
@@ -65,7 +60,7 @@ package() {
"$pkgdir/usr/share/doc/$pkgname"
# desktop shortcut
- install -Dm644 "$pkgname-$pkgver-$_pkgtype/src/$pkgname.desktop" \
+ install -Dm644 "$pkgname-$pkgver/src/$pkgname.desktop" \
"$pkgdir/usr/share/applications/$pkgname.desktop"
}
diff --git a/freetype2.patch b/freetype2.patch
deleted file mode 100644
index 9a076dac740f..000000000000
--- a/freetype2.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/Makefile 2023-01-08 11:38:30.203521345 +0000
-+++ b/Makefile 2023-01-08 12:03:51.732619208 +0000
-@@ -292,6 +292,7 @@
- # SDL Pango is needed to render complex scripts like Thai and Arabic
- SDL2_PANGO_LIB:=$(call linktest,SDL2_Pango,-lSDL2_Pango,$(SDL_LIBS))
- NOPANGOFLAG:=$(if $(SDL2_PANGO_LIB),,-DNO_SDLPANGO$(warning -lSDL2_Pango failed, no scripts for you!))
-+SDL2_PANGO_CFLAGS:=$(shell $(PKG_CONFIG) SDL2_Pango --cflags)
-
- SDL_LIBS+=$(SDL_MIXER_LIB) $(SDL2_PANGO_LIB)
-
-@@ -1213,7 +1215,7 @@
- src/get_fname.h src/debug.h
- @echo
- @echo "...Compiling font support..."
-- @$(CC) $(CFLAGS) $(DEBUG_FLAGS) $(SDL_CFLAGS) $(DEFS) $(ARCH_DEFS) \
-+ @$(CC) $(CFLAGS) $(DEBUG_FLAGS) $(SDL_CFLAGS) $(SDL2_PANGO_CFLAGS) $(DEFS) $(ARCH_DEFS) \
- -c src/fonts.c -o obj/fonts.o
-
- obj/dirwalk.o: src/dirwalk.c src/dirwalk.h src/progressbar.h src/fonts.h \
-@@ -1221,7 +1221,7 @@
- src/debug.h
- @echo
- @echo "...Compiling directory-walking support..."
-- @$(CC) $(CFLAGS) $(DEBUG_FLAGS) $(SDL_CFLAGS) $(DEFS) $(ARCH_DEFS) \
-+ @$(CC) $(CFLAGS) $(DEBUG_FLAGS) $(SDL_CFLAGS) $(SDL2_PANGO_CFLAGS) $(DEFS) $(ARCH_DEFS) \
- -c src/dirwalk.c -o obj/dirwalk.o
-
- obj/cursor.o: src/cursor.c src/cursor.h src/debug.h