summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
2 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b044e41e3a2..7204b991f89d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,14 +4,25 @@ pkgbase = tuxpaint
pkgrel = 1
url = https://tuxpaint.org/
arch = x86_64
- license = GPL
+ license = GPL-2.0-only
makedepends = gperf
makedepends = setconf
makedepends = imagemagick
+ depends = glibc
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = zlib
+ depends = fontconfig
+ depends = libpng
+ depends = pango
+ depends = glib2
+ depends = freetype2
+ depends = harfbuzz
depends = fribidi
depends = libpaper
depends = librsvg
depends = libimagequant
+ depends = sdl2
depends = sdl2_image
depends = sdl2_gfx
depends = sdl2_mixer
@@ -20,6 +31,7 @@ pkgbase = tuxpaint
optdepends = tuxpaint-stamps: more stamps
optdepends = tuxpaint-config: configuration manager
optdepends = python2: zh_tw font generator script
+ optdepends = bash: for tp-magic-config, zh_tw doc generstor, tuxpaint-import scripts
backup = etc/tuxpaint/tuxpaint.conf
source = https://downloads.sourceforge.net/sourceforge/tuxpaint/tuxpaint-0.9.32.tar.gz
sha256sums = 09cce22241481dc1360fc4bc5d4da1d31815d7a2563b9e9fa217a672ba974bf2
diff --git a/PKGBUILD b/PKGBUILD
index 01e43a203ed2..5df3d84ee97a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,16 @@ pkgrel=1
pkgdesc='Drawing program designed for young children'
arch=('x86_64')
url='https://tuxpaint.org/'
-license=('GPL')
+license=('GPL-2.0-only')
backup=('etc/tuxpaint/tuxpaint.conf')
-depends=('fribidi' 'libpaper' 'librsvg' 'libimagequant' 'sdl2_image'
- 'sdl2_gfx' 'sdl2_mixer' 'sdl2_pango' 'sdl2_ttf')
+depends=('glibc' 'cairo' 'gdk-pixbuf2' 'zlib' 'fontconfig' 'libpng' 'pango'
+ 'glib2' 'freetype2' 'harfbuzz' 'fribidi' 'libpaper' 'librsvg' 'libimagequant'
+ 'sdl2' 'sdl2_image' 'sdl2_gfx' 'sdl2_mixer' 'sdl2_pango' 'sdl2_ttf')
makedepends=('gperf' 'setconf' 'imagemagick')
optdepends=('tuxpaint-stamps: more stamps'
'tuxpaint-config: configuration manager'
- 'python2: zh_tw font generator script')
+ 'python2: zh_tw font generator script'
+ 'bash: for tp-magic-config, zh_tw doc generstor, tuxpaint-import scripts')
source=("https://downloads.sourceforge.net/sourceforge/tuxpaint/$pkgname-$pkgver.tar.gz")
sha256sums=('09cce22241481dc1360fc4bc5d4da1d31815d7a2563b9e9fa217a672ba974bf2')
@@ -25,7 +27,7 @@ prepare() {
# python2 fix
for f in docs/outdated/zh_tw/mkTuxpaintIM.py fonts/locale/zh_tw_docs/maketuxfont.py; do
- sed -i '0,/on/s//on2/' $f
+ sed -i '0,/python$/s//python2/' $f
done
# native fullscreen by default