summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD9
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 09883a7e302d..bd86c3af010b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,13 +4,16 @@ pkgbase = tuxpaint-config
pkgrel = 1
url = https://www.tuxpaint.org/
arch = x86_64
- license = GPL
- depends = tuxpaint
+ license = GPL-2.0-only
depends = fltk
- depends = libxft
- depends = libxext
+ depends = fontconfig
+ depends = gcc-libs
+ depends = glibc
+ depends = hicolor-icon-theme
+ depends = libpaper
depends = libunibreak
- options = !makeflags
+ depends = pango
+ optdepends = tuxpaint: ability to use tuxpaint provided fonts
source = https://downloads.sourceforge.net/sourceforge/tuxpaint/tuxpaint-config-0.0.23.tar.gz
sha256sums = 95d7502a1b29fbf0e157793e634197bf08a6b6ae3f604e2991d117d2fae70135
diff --git a/PKGBUILD b/PKGBUILD
index f8955d2077c1..c997f3ea18be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,15 @@ pkgrel=1
pkgdesc='Tux Paint configuration tool'
arch=('x86_64')
url='https://www.tuxpaint.org/'
-license=('GPL')
-depends=('tuxpaint' 'fltk' 'libxft' 'libxext' 'libunibreak')
-options=('!makeflags')
+license=('GPL-2.0-only')
+depends=('fltk' 'fontconfig' 'gcc-libs' 'glibc' 'hicolor-icon-theme'
+ 'libpaper' 'libunibreak' 'pango')
+optdepends=('tuxpaint: ability to use tuxpaint provided fonts')
source=("https://downloads.sourceforge.net/sourceforge/tuxpaint/$pkgname-$pkgver.tar.gz")
sha256sums=('95d7502a1b29fbf0e157793e634197bf08a6b6ae3f604e2991d117d2fae70135')
build() {
- make -C "$pkgname-$pkgver" PREFIX=/usr
+ make -C "$pkgname-$pkgver" CFLAGS="$CFLAGS $LDFLAGS" PREFIX=/usr
}
package() {