aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9cf695f7391
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = twstools
+ pkgdesc = Command line tools around Interactive Brokers TWS API
+ pkgver = 0.4.3
+ pkgrel = 1
+ url = https://github.com/rudimeier/twstools
+ arch = any
+ license = BSD
+ depends = libtwsapi
+ source = https://bitbucket.org/rudimeier/twstools/downloads/twstools-0.4.3.tar.gz
+ md5sums = 527f71d5def8359ffd5c7b4bc8a07547
+
+pkgname = twstools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..191c56e42def
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ben Alex <ben.alex@acegi.com.au>
+
+# See https://github.com/benalexau/twstools-aur for AUR PKGBUILD history
+
+pkgname=twstools
+pkgver=0.4.3
+pkgrel=1
+pkgdesc='Command line tools around Interactive Brokers TWS API'
+arch=('any')
+url="https://github.com/rudimeier/twstools"
+license=('BSD')
+depends=('libtwsapi')
+source=('https://bitbucket.org/rudimeier/twstools/downloads/twstools-0.4.3.tar.gz')
+md5sums=('527f71d5def8359ffd5c7b4bc8a07547')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install
+}