aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
-rw-r--r--README.md10
-rw-r--r--uau.install12
5 files changed, 27 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d5da2a60de9..6dcd74ca223e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = uau
pkgdesc = unattended upgrades for Arch. Schedule automatic upgrades while respecting the recommended upgrade process (Arch wiki - System maintenance).
- pkgver = 1.1.0
- pkgrel = 3
+ pkgver = 2.1.0
+ pkgrel = 2
url = https://github.com/steadfasterX/arch_uau
install = uau.install
arch = any
license = LGPL3
makedepends = git
depends = aur-comment-fetcher-git
- depends = checkupdates+aur
+ depends = archnews2
depends = sudo
depends = pacman
depends = python3-memoizedb
- optdepends = ssmtp: to provide the sendmail like mail command
+ optdepends = ssmtp: extreme simple Mail Transport Agent
+ optdepends = s-nail: to provide the sendmail like mail command
+ optdepends = yay
backup = etc/unattended-arch-upgrade.conf
backup = etc/unattended-arch-upgrade.ignore
- source = https://github.com/steadfasterX/arch_uau/archive/v1.1.0.tar.gz
- md5sums = SKIP
+ source = https://github.com/steadfasterX/arch_uau/archive/v2.1.0.tar.gz
+ md5sums = 6414fe93ccb8521664282c34234a89b4
pkgname = uau
-
diff --git a/.gitignore b/.gitignore
index 82f4af9beb14..ed47f3cd9aa4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
pkg/*
src/*
*.swp
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
index b407812a28ed..c74d377acb57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: steadfasterX <steadfasterX [at] gmail -dot- com>
pkgname=uau
-pkgver=1.1.0
-pkgrel=3
+pkgver=2.1.0
+pkgrel=2
pkgdesc="unattended upgrades for Arch. Schedule automatic upgrades while respecting the recommended upgrade process (Arch wiki - System maintenance)."
arch=('any')
url="https://github.com/steadfasterX/arch_uau"
license=('LGPL3')
-depends=('aur-comment-fetcher-git' 'checkupdates+aur' 'sudo' 'pacman' 'python3-memoizedb')
+depends=('aur-comment-fetcher-git' 'archnews2' 'sudo' 'pacman' 'python3-memoizedb')
makedepends=('git')
-optdepends=('ssmtp: to provide the sendmail like mail command')
+optdepends=('ssmtp: extreme simple Mail Transport Agent' 's-nail: to provide the sendmail like mail command' 'yay')
backup=('etc/unattended-arch-upgrade.conf' 'etc/unattended-arch-upgrade.ignore')
source=("https://github.com/steadfasterX/arch_$pkgname/archive/v$pkgver.tar.gz")
-md5sums=('SKIP')
+md5sums=('6414fe93ccb8521664282c34234a89b4')
BINFIX=usr/local/bin
SUDOERS=etc/sudoers.d
SYSD=etc/systemd/system
@@ -31,11 +31,11 @@ package() {
install -d -m 0750 $pkgdir/${SUDOERS}
install -o ${USER} -g ${GROUP} -m 0700 conf/uau_sudo $pkgdir/${SUDOERS}/uau_sudo
- install -o ${USER} -g ${GROUP} -m 0744 conf/unattended-arch-upgrade.conf $pkgdir/etc/unattended-arch-upgrade.conf
- install -o ${USER} -g ${GROUP} -m 0744 conf/unattended-arch-upgrade.ignore $pkgdir/etc/unattended-arch-upgrade.ignore
+ install -o ${USER} -g ${GROUP} -m 0644 conf/unattended-arch-upgrade.conf $pkgdir/etc/unattended-arch-upgrade.conf
+ install -o ${USER} -g ${GROUP} -m 0644 conf/unattended-arch-upgrade.ignore $pkgdir/etc/unattended-arch-upgrade.ignore
install -o ${USER} -g ${GROUP} -m 0755 bin/* $pkgdir/${BINFIX}/
ln -sfv uau $pkgdir/${BINFIX}/unattended-upgrade
- install -o ${USER} -g ${GROUP} -m 0755 conf/archnews_cron $pkgdir/etc/cron.d/archnews
+ install -o ${USER} -g ${GROUP} -m 0644 conf/archnews_cron $pkgdir/etc/cron.d/archnews
install -o ${USER} -g ${GROUP} -m 0755 conf/unattended-arch-upgrade.service $pkgdir/${SYSD}/unattended-arch-upgrade.service
install -o ${USER} -g ${GROUP} -m 0755 conf/unattended-arch-upgrade.timer $pkgdir/${SYSD}/unattended-arch-upgrade.timer
@@ -44,6 +44,5 @@ package() {
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
install -D -m644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
}
diff --git a/README.md b/README.md
index 181e988a6829..9376c9b0af26 100644
--- a/README.md
+++ b/README.md
@@ -1,6 +1,6 @@
## uAu (unattended Arch upgrade) package build
-package build for uAu (https://github.com/steadfasterX/arch_uau/)
+package build for uau (https://github.com/steadfasterX/arch_uau/)
## Guide
@@ -8,13 +8,13 @@ package build for uAu (https://github.com/steadfasterX/arch_uau/)
`gpg --receive-keys 1D1F0DC78F173680`
-`trizen -S --noconfirm aur-comment-fetcher-git checkupdates+aur python3-memoizedb`
+`yay -S --noconfirm aur-comment-fetcher-git checkupdates+aur python3-memoizedb`
#### optional: Install mail
If you have the command `mail` **not** available on your system:
-`sudo pacman -S ssmtp`
+`yay -S ssmtp s-nail`
I use and have tested only sstmp but every sendmail-like `mail` cmd will do.
@@ -37,6 +37,6 @@ All options are well documented in that conf file. Just adjust it to your needs.
This one should be used VERY carefully as ignoring packages can result in unexpected system behavior.
Each "IgnorePkg=" can just contain 1 package name.
-* Bad example: libraries
-* Good example: kernel
+Bad example: libraries
+Good example: kernel
diff --git a/uau.install b/uau.install
index 3fd20a10d321..c73ec6f405cd 100644
--- a/uau.install
+++ b/uau.install
@@ -1,4 +1,3 @@
-
post_install() {
. /etc/unattended-arch-upgrade.conf
@@ -6,15 +5,10 @@ post_install() {
# no account expiry, never set to inactive, no password expiry
chage -E -1 -I -1 -m -1 -M -1 $UPDATEUSER
- # install archnews and ensure it is a supported version
- mkdir $ANEWSDIR
- git clone $GITANEWS $ANEWSDIR
- cd $ANEWSDIR
- git checkout $ANEWREL
-
systemctl enable unattended-arch-upgrade.timer
systemctl start unattended-arch-upgrade.timer
systemctl list-timers unattended-arch-upgrade.timer
+ systemctl daemon-reload
sed -i '/\[options\]/a Include=/etc/unattended-arch-upgrade.ignore' $PACCONF
@@ -24,6 +18,10 @@ post_install() {
chmod 644 /etc/cron.d/archnews
}
+post_upgrade(){
+ systemctl daemon-reload
+}
+
pre_remove() {
. /etc/unattended-arch-upgrade.conf