summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--extern-packet_counter_max.patch12
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fe310910c98..5d50bcc42047 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ubertooth
pkgdesc = Open source wireless development platform suitable for Bluetooth experimentation
pkgver = 2018.12.R1
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/greatscottgadgets/ubertooth/
arch = x86_64
arch = i686
@@ -16,7 +16,9 @@ pkgbase = ubertooth
optdepends = qt5-declarative
optdepends = python-pyside2
source = https://github.com/greatscottgadgets/ubertooth/releases/download/2018-12-R1/ubertooth-2018-12-R1.tar.xz
+ source = extern-packet_counter_max.patch
sha256sums = 0042daa79db0f4148a0255cdf05aa57006e23ac36edf7024e9e99ccc4892867b
+ sha256sums = 6a88a2e000e02b1dd31dee125cbe9f8713c2c397023ae9ee8f6e57aa71fa9598
pkgname = ubertooth
diff --git a/PKGBUILD b/PKGBUILD
index b6b28aae1d43..1defe99ed5af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=ubertooth
pkgver=2018.12.R1
_pkgver=2018-12-R1
-pkgrel=5
+pkgrel=6
pkgdesc="Open source wireless development platform suitable for Bluetooth experimentation"
url="https://github.com/greatscottgadgets/ubertooth/"
arch=('x86_64' 'i686')
@@ -9,8 +9,13 @@ license=('GPL')
depends=('bluez-libs' 'libbtbb>=2018.12.R1' 'libusb' 'libpcap' 'python-numpy' 'python-pyusb')
optdepends=('qt5-declarative' 'python-pyside2')
makedepends=('cmake')
-source=("https://github.com/greatscottgadgets/ubertooth/releases/download/${_pkgver}/ubertooth-${_pkgver}.tar.xz")
-sha256sums=('0042daa79db0f4148a0255cdf05aa57006e23ac36edf7024e9e99ccc4892867b')
+source=("https://github.com/greatscottgadgets/ubertooth/releases/download/${_pkgver}/ubertooth-${_pkgver}.tar.xz" "extern-packet_counter_max.patch")
+sha256sums=('0042daa79db0f4148a0255cdf05aa57006e23ac36edf7024e9e99ccc4892867b' '6a88a2e000e02b1dd31dee125cbe9f8713c2c397023ae9ee8f6e57aa71fa9598')
+
+prepare() {
+ cd "${pkgname}-${_pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/extern-packet_counter_max.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${_pkgver}/host/"
diff --git a/extern-packet_counter_max.patch b/extern-packet_counter_max.patch
new file mode 100644
index 000000000000..0356a431df3a
--- /dev/null
+++ b/extern-packet_counter_max.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text ubertooth-2018-12-R1.orig/host/libubertooth/src/ubertooth_callback.c ubertooth-2018-12-R1.new/host/libubertooth/src/ubertooth_callback.c
+--- ubertooth-2018-12-R1.orig/host/libubertooth/src/ubertooth_callback.c 2018-12-04 22:21:07.000000000 -0800
++++ ubertooth-2018-12-R1.new/host/libubertooth/src/ubertooth_callback.c 2020-10-21 20:23:38.173202698 -0700
+@@ -27,7 +27,7 @@
+
+ #include "ubertooth_callback.h"
+
+-unsigned int packet_counter_max;
++extern unsigned int packet_counter_max;
+
+ static int8_t cc2400_rssi_to_dbm( const int8_t rssi )
+ {