summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 324c4656050a..e364a8cef57c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ubertooth-git
pkgdesc = open source wireless development platform suitable for Bluetooth experimentation
- pkgver = 2020.12.R1.r33.ge0fd34d
+ pkgver = 2020.12.R1.r34.g0aae62e
pkgrel = 2
url = https://github.com/greatscottgadgets/ubertooth
arch = x86_64
@@ -14,7 +14,11 @@ pkgbase = ubertooth-git
depends = libpcap
depends = python
depends = python-libusb1
+ provides = ubertooth
+ conflicts = ubertooth
source = git+https://github.com/greatscottgadgets/ubertooth/
+ source = specan-version.patch::https://github.com/greatscottgadgets/ubertooth/commit/6fb9858b3d3daf511f70cb7c5db2b6316031972a.patch
md5sums = SKIP
+ md5sums = a85952153d7e1f233d790a2bf363ce80
pkgname = ubertooth-git
diff --git a/PKGBUILD b/PKGBUILD
index ae415ff373aa..12742184ba6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,18 @@
_gitname=ubertooth
pkgname=ubertooth-git
-pkgver=2020.12.R1.r33.ge0fd34d
+pkgver=2020.12.R1.r34.g0aae62e
pkgrel=2
-pkgdesc="open source wireless development platform suitable for Bluetooth experimentation"
-url="https://github.com/greatscottgadgets/ubertooth"
+pkgdesc='open source wireless development platform suitable for Bluetooth experimentation'
+url='https://github.com/greatscottgadgets/ubertooth'
+provides=('ubertooth')
+conflicts=('ubertooth')
arch=('x86_64' 'i686')
license=('GPL2')
depends=('libbtbb-git' 'libusb' 'libpcap' 'python' 'python-libusb1')
makedepends=('git' 'cmake' 'python-setuptools')
-source=(git+https://github.com/greatscottgadgets/ubertooth/)
-md5sums=('SKIP')
+source=('git+https://github.com/greatscottgadgets/ubertooth/' 'specan-version.patch::https://github.com/greatscottgadgets/ubertooth/commit/6fb9858b3d3daf511f70cb7c5db2b6316031972a.patch')
+md5sums=('SKIP' 'a85952153d7e1f233d790a2bf363ce80')
pkgver() {
@@ -20,6 +22,11 @@ pkgver() {
git describe --tags --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_gitname"
+ git am "$srcdir/specan-version.patch"
+}
+
build() {
cd "$_gitname/host/"
mkdir -p build