summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD48
3 files changed, 35 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e52f29827c9..c743837b1752 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = ubuntu-wallpapers
- pkgdesc = The default wallpapers for Ubuntu (from 9.10 to 18.04)
- pkgver = 19.04.2
+ pkgdesc = The default Wallpapers for Ubuntu
+ pkgver = 24.04.2
pkgrel = 1
url = https://launchpad.net/ubuntu-wallpapers
arch = any
- groups = unity-extra
- license = GPL
- makedepends = libxslt
- makedepends = python2-distutils-extra
- source = https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-wallpapers_19.04.2.orig.tar.gz
- source = https://launchpad.net/ubuntu/+archive/primary/+files/ubuntu-wallpapers_19.04.2-0ubuntu1.debian.tar.xz
- sha512sums = 324812015f04c7286e9f90d73bb671013fff386eaf7933998a1199ebc24dbd1bba4ca3f8fc526afe4e26df738662d6d033a90f99195380b7fb4cf09feb8e631b
- sha512sums = 3806dab05de2f3733d36cea7aaced08be400f9302bf72e70977685e3e84b8b135e5d85be64356b4b8f46d1cfcb2be2519d13e05389b592df83e7fc14e9ffd97a
+ license = custom
+ makedepends = python-distutils-extra
+ makedepends = python-setuptools
+ source = http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers/ubuntu-wallpapers_24.04.2.orig.tar.gz
+ sha512sums = 18cbf8498d2445350053fe472b7d081ae92df01911f15b5bd96c912f4ebb7dd6a4bfe8f90d25a16aba3f8d317faf1fbe8f381d437e95d669cf0d2dc06c898a28
pkgname = ubuntu-wallpapers
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..62bb40b21878
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!/*.patch \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 181b258cedaa..eb0f5fcc4bed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
-# Maintainer: Louis Tim Larsen <louis(a)louis.dk>
-# Maintainer: Michael Healy <horsemanoffaith@gmail.com>
+# Maintainer: Sidney Kuyateh <autinerd-arch@kuyateh.eu>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Louis Tim Larsen <louis(a)louis.dk>
+# Contributor: Michael Healy <horsemanoffaith@gmail.com>
# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
-# vercheck-pkgbuild: auto
-# vercheck-ubuntu: name=${pkgname}, repo=artful
+# Contributor: SoftwareRat <chenxiaolong@cxl.epac.to>
+# Contributor: Ewout van Mansom <ewout@vanmansom.name>
-pkgname=ubuntu-wallpapers
-_ubuntu_rel=0ubuntu1
-pkgver=19.04.2
+pkgname='ubuntu-wallpapers'
+pkgver=24.04.2
pkgrel=1
-pkgdesc="The default wallpapers for Ubuntu (from 9.10 to 18.04)"
-arch=(any)
-url="https://launchpad.net/ubuntu-wallpapers"
-license=(GPL)
-groups=(unity-extra)
-makedepends=(libxslt python2-distutils-extra)
-source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}.orig.tar.gz"
- "https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}-${_ubuntu_rel}.debian.tar.xz")
-sha512sums=('324812015f04c7286e9f90d73bb671013fff386eaf7933998a1199ebc24dbd1bba4ca3f8fc526afe4e26df738662d6d033a90f99195380b7fb4cf09feb8e631b'
- '3806dab05de2f3733d36cea7aaced08be400f9302bf72e70977685e3e84b8b135e5d85be64356b4b8f46d1cfcb2be2519d13e05389b592df83e7fc14e9ffd97a')
+pkgdesc='The default Wallpapers for Ubuntu'
+arch=('any')
+url='https://launchpad.net/ubuntu-wallpapers'
+_pool_url='http://archive.ubuntu.com/ubuntu/pool/main'
+license=('custom')
+makedepends=('python-distutils-extra' 'python-setuptools')
-prepare() {
- cd "${pkgname}-${pkgver}"
-
- # The setup.py script reads the package version from debian/*
- ln -s ../debian .
-}
+# https://packages.ubuntu.com/source/ubuntu-wallpapers
+# http://archive.ubuntu.com/ubuntu/pool/main/u/ubuntu-wallpapers/
+source=(
+ "${_pool_url}/${pkgname::1}/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz"
+)
+sha512sums=('18cbf8498d2445350053fe472b7d081ae92df01911f15b5bd96c912f4ebb7dd6a4bfe8f90d25a16aba3f8d317faf1fbe8f381d437e95d669cf0d2dc06c898a28')
package() {
- cd "${pkgname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
+ cd "${pkgname}_${pkgver}.orig"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dvm644 'debian/copyright' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}