summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD73
2 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ae0eea2d178
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = ubuntu1804lts-python3
+ pkgdesc = Python3 version matching current version of Ubuntu's python3.
+ pkgver = 3.6.8
+ pkgrel = 1
+ url = http://www.python.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = tk
+ makedepends = sqlite
+ makedepends = bluez-libs
+ makedepends = mpdecimal
+ makedepends = pkgconf
+ depends = expat
+ depends = bzip2
+ depends = gdbm
+ depends = openssl
+ depends = libffi
+ depends = zlib
+ optdepends = tk: for tkinter
+ optdepends = sqlite
+ options = !makeflags
+ source = http://www.python.org/ftp/python/3.6.8/Python-3.6.8.tar.xz
+ sha256sums = 35446241e995773b1bed7d196f4b624dadcadc8429f26282e756b2fb8a351193
+
+pkgname = ubuntu1804lts-python3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b21a1c7da84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,73 @@
+# Maintainer: Robert Csordas (xdever@gmail.com)
+# Based on https://aur.archlinux.org/packages/python36/
+
+pkgname=ubuntu1804lts-python3
+pkgver=3.6.8
+pkgrel=1
+_pybasever=3.6
+_pymajver=3
+pkgdesc="Python3 version matching current version of Ubuntu's python3."
+arch=('i686' 'x86_64')
+license=('custom')
+url="http://www.python.org/"
+depends=('expat' 'bzip2' 'gdbm' 'openssl' 'libffi' 'zlib')
+makedepends=('tk' 'sqlite' 'bluez-libs' 'mpdecimal' 'pkgconf')
+optdepends=('tk: for tkinter' 'sqlite')
+options=('!makeflags')
+source=(http://www.python.org/ftp/python/${pkgver}/Python-${pkgver}.tar.xz)
+sha256sums=('35446241e995773b1bed7d196f4b624dadcadc8429f26282e756b2fb8a351193')
+
+prepare() {
+ cd "${srcdir}/Python-${pkgver}"
+
+ # FS#23997
+ sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
+
+ # Ensure that we are using the system copy of various libraries (expat, zlib and libffi),
+ # rather than copies shipped in the tarball
+ rm -rf Modules/expat
+ rm -rf Modules/zlib
+ rm -rf Modules/_ctypes/{darwin,libffi}*
+ rm -rf Modules/_decimal/libmpdec
+}
+
+build() {
+ cd "${srcdir}/Python-${pkgver}"
+
+ CFLAGS=-DOPENSSL_NO_SSL2 ./configure --prefix=/usr \
+ --enable-shared \
+ --with-threads \
+ --with-computed-gotos \
+ --enable-ipv6 \
+ --with-system-expat \
+ --with-dbmliborder=gdbm:ndbm \
+ --with-system-libmpdec \
+ --enable-loadable-sqlite-extensions \
+ --without-ensurepip \
+ --enable-optimizations
+
+ make
+}
+
+package() {
+ cd "${srcdir}/Python-${pkgver}"
+ # altinstall: /usr/bin/pythonX.Y but not /usr/bin/python or /usr/bin/pythonX
+ make DESTDIR="${pkgdir}" altinstall maninstall
+
+ # Avoid conflicts with the main 'python' package, once Python 3.7 is standard.
+ rm "${pkgdir}/usr/lib/libpython${_pymajver}.so"
+ rm "${pkgdir}/usr/share/man/man1/python${_pymajver}.1"
+
+ # Fix FS#22552
+ ln -sf ../../libpython${_pybasever}m.so \
+ "${pkgdir}/usr/lib/python${_pybasever}/config-${_pybasever}m-${CARCH}-linux-gnu/libpython${_pybasever}m.so"
+
+ # Fix pycairo build
+ ln -sf python${_pybasever}m-config "${pkgdir}/usr/bin/python${_pybasever}-config"
+
+ # Clean-up reference to build directory
+ sed -i "s|$srcdir/Python-${pkgver}:||" "$pkgdir/usr/lib/python${_pybasever}/config-${_pybasever}m-${CARCH}-linux-gnu/Makefile"
+
+ # License
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}