summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e3337582fb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Apr 24 00:37:43 UTC 2016
+pkgbase = uclogic-tools
+ pkgdesc = Show diagnostic information from UC-Logic graphics tablets (rebranded as Huion, Yiynova, Ugee, Monoprice, Turcom and others)
+ pkgver = 4
+ pkgrel = 1
+ url = https://github.com/DIGImend/uclogic-tools
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = libusb
+ source = https://github.com/DIGImend/uclogic-tools/releases/download/v4/uclogic-tools-4.tar.gz
+ sha1sums = d8bbbe49490bb6681e55fc6790d31c787b7bf3d5
+
+pkgname = uclogic-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb957952d1cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: sinkuu <sinkuupump@gmail.com>
+
+pkgname=uclogic-tools
+pkgver=4
+pkgrel=1
+pkgdesc="Show diagnostic information from UC-Logic graphics tablets (rebranded as Huion, Yiynova, Ugee, Monoprice, Turcom and others)"
+arch=('i686' 'x86_64')
+url="https://github.com/DIGImend/uclogic-tools"
+license=('GPL2')
+depends=('libusb')
+source=("https://github.com/DIGImend/uclogic-tools/releases/download/v$pkgver/uclogic-tools-$pkgver.tar.gz")
+sha1sums=('d8bbbe49490bb6681e55fc6790d31c787b7bf3d5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" install
+}