summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD50
-rw-r--r--patch-backup-lynxit.c20
-rw-r--r--patch-libdiscimage-misc_z.c10
-rw-r--r--patch-libdiscimage-unzip.h13
-rw-r--r--patch-misc-archive.c10
-rw-r--r--patch-misc-unzip.h13
-rw-r--r--patch-ucon64.c21
-rw-r--r--patch-ucon64_misc.c11
9 files changed, 168 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01dec5067d0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ucon64
+ pkgdesc = A ROM backup tool and emulator's Swiss Army knife program.
+ pkgver = 2.0.0
+ pkgrel = 4
+ url = http://ucon64.sourceforge.net/index.php
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = zlib
+ source = http://downloads.sourceforge.net/ucon64/ucon64-2.0.0-src.tar.gz
+ source = patch-backup-lynxit.c
+ source = patch-libdiscimage-misc_z.c
+ source = patch-libdiscimage-unzip.h
+ source = patch-misc-archive.c
+ source = patch-misc-unzip.h
+ source = patch-ucon64.c
+ source = patch-ucon64_misc.c
+
+pkgname = ucon64
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3d3f092f27c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer : Paula Breton <paula@parashep.com>
+# Contributor: robb_force <robb_force@holybuffalo.net>
+
+pkgname=ucon64
+pkgver=2.0.0
+pkgrel=4
+pkgdesc="A ROM backup tool and emulator's Swiss Army knife program."
+arch=('i686' 'x86_64')
+url="http://ucon64.sourceforge.net/index.php"
+license="GPL"
+depends=('zlib')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-src.tar.gz \
+ patch-backup-lynxit.c \
+ patch-libdiscimage-misc_z.c \
+ patch-libdiscimage-unzip.h \
+ patch-misc-archive.c \
+ patch-misc-unzip.h \
+ patch-ucon64.c \
+ patch-ucon64_misc.c)
+md5sums=('33804256edb265d43bc3dbb9ada4441a'
+ '0c315bce4b590749b7451b33f86d5b2d'
+ '3a405c6696069b8799dce85c21c6c6e9'
+ '249aaa950fba7bc9983b4dafdeaf37ab'
+ '42057845212bf93dee24584912316494'
+ 'fbd555b1fa8b0d6a1547fcca5110e8a9'
+ 'a991ce0999b9724dec816fb1747b1237'
+ 'edac4423575708755e7dc1a603538c01')
+
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}-src/src
+ for i in ../../patch*; do patch -p0 < $i; echo $i; done
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}-src/src
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}-src/src
+
+ install -Dm775 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+
+ if [ -f libdiscmage/discmage.so ]; then
+ install -Dm755 libdiscmage/discmage.so ${pkgdir}/usr/lib/discmage.so
+ elif [ -f discmage.so ]; then
+ install -Dm755 discmage.so ${pkgdir}/usr/lib/discmage.so
+ fi
+}
diff --git a/patch-backup-lynxit.c b/patch-backup-lynxit.c
new file mode 100644
index 000000000000..e436023df313
--- /dev/null
+++ b/patch-backup-lynxit.c
@@ -0,0 +1,20 @@
+--- backup/lynxit.c.orig 2013-02-24 18:40:11.525942823 -0800
++++ backup/lynxit.c 2013-02-24 18:46:25.101942911 -0800
+@@ -561,7 +561,7 @@
+ return FALSE;
+ }
+
+- if (strcmp (header.magic, "LYNX") != 0)
++ if (memcmp (header.magic, "LYNX", sizeof(header.magic)) != 0)
+ {
+ MESSAGE (("ERROR : %s is not a lynx image\n", filename));
+ fclose (fp);
+@@ -682,7 +682,7 @@
+ #endif
+
+ memset (&header, 0, sizeof (st_lnx_header_t));
+- strcpy (header.magic, MAGIC_STRING);
++ memcpy (header.magic, MAGIC_STRING, sizeof(header.magic));
+ strcpy (header.cartname, cartname);
+ strcpy (header.manufname, manufname);
+ header.page_size_bank0 = cart_analyse (BANK0);
diff --git a/patch-libdiscimage-misc_z.c b/patch-libdiscimage-misc_z.c
new file mode 100644
index 000000000000..b7e80e85ac12
--- /dev/null
+++ b/patch-libdiscimage-misc_z.c
@@ -0,0 +1,10 @@
+--- libdiscmage/misc_z.c.orig 2013-02-24 18:50:29.788944291 -0800
++++ libdiscmage/misc_z.c 2013-02-24 18:51:00.403942771 -0800
+@@ -27,6 +27,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <sys/stat.h>
++#define Z_SOLO
+ #include <zlib.h>
+ #include "misc_z.h"
+ #include "misc.h"
diff --git a/patch-libdiscimage-unzip.h b/patch-libdiscimage-unzip.h
new file mode 100644
index 000000000000..81d26859cd89
--- /dev/null
+++ b/patch-libdiscimage-unzip.h
@@ -0,0 +1,13 @@
+--- libdiscmage/unzip.h.orig 2013-02-24 18:48:58.073946338 -0800
++++ libdiscmage/unzip.h 2013-02-24 18:50:15.451943149 -0800
+@@ -49,6 +49,10 @@
+ #include "zlib.h"
+ #endif
+
++#ifndef OF
++#define OF(x) x
++#endif
++
+ #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
+ /* like the STRICT of WIN32, we define a pointer that cannot be converted
+ from (void*) without cast */
diff --git a/patch-misc-archive.c b/patch-misc-archive.c
new file mode 100644
index 000000000000..a9c5776aae9d
--- /dev/null
+++ b/patch-misc-archive.c
@@ -0,0 +1,10 @@
+--- misc/archive.c.orig 2013-02-24 18:51:23.157943222 -0800
++++ misc/archive.c 2013-02-24 18:55:00.666943043 -0800
+@@ -27,6 +27,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <sys/stat.h>
++#define Z_SOLO
+ #include <zlib.h>
+ #ifdef HAVE_BYTESWAP_H
+ #include <byteswap.h>
diff --git a/patch-misc-unzip.h b/patch-misc-unzip.h
new file mode 100644
index 000000000000..cc99ae29d53e
--- /dev/null
+++ b/patch-misc-unzip.h
@@ -0,0 +1,13 @@
+--- misc/unzip.h.orig 2013-02-24 18:47:37.112077049 -0800
++++ misc/unzip.h 2013-02-24 18:48:46.040942781 -0800
+@@ -49,6 +49,10 @@
+ #include "zlib.h"
+ #endif
+
++#ifndef OF
++#define OF(x) x
++#endif
++
+ #if defined(STRICTUNZIP) || defined(STRICTZIPUNZIP)
+ /* like the STRICT of WIN32, we define a pointer that cannot be converted
+ from (void*) without cast */
diff --git a/patch-ucon64.c b/patch-ucon64.c
new file mode 100644
index 000000000000..12b0fa6c12a9
--- /dev/null
+++ b/patch-ucon64.c
@@ -0,0 +1,21 @@
+--- ucon64.c.orig 2005-01-06 15:43:44.000000000 -0800
++++ ucon64.c 2013-02-24 23:25:47.094966291 -0800
+@@ -1394,17 +1394,7 @@
+ #ifdef DLOPEN
+ ucon64.discmage_path;
+ #else
+-#if defined __MSDOS__
+- "discmage.dxe";
+-#elif defined __CYGWIN__ || defined _WIN32
+- "discmage.dll";
+-#elif defined __APPLE__ // Mac OS X actually
+- "libdiscmage.dylib";
+-#elif defined __unix__ || defined __BEOS__
+- "libdiscmage.so";
+-#else
+- "unknown";
+-#endif
++ "%%PREFIX%%/lib/libdiscmage.so";
+ #endif
+
+ if (!ucon64.discmage_enabled)
diff --git a/patch-ucon64_misc.c b/patch-ucon64_misc.c
new file mode 100644
index 000000000000..32b4418ea19c
--- /dev/null
+++ b/patch-ucon64_misc.c
@@ -0,0 +1,11 @@
+--- ucon64_misc.c.orig 2013-02-24 22:48:15.577943937 -0800
++++ ucon64_misc.c 2013-02-24 22:51:28.521008805 -0800
+@@ -1698,7 +1698,7 @@
+ #elif defined __APPLE__ // Mac OS X actually
+ "~/.ucon64/discmage.dylib",
+ #elif defined __unix__ || defined __BEOS__
+- "~/.ucon64/discmage.so",
++ "%%PREFIX%%/lib/libdiscmage.so",
+ #else
+ "",
+ #endif