summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--remove_check.patch16
3 files changed, 31 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcc1c961fbbe..b8a71b5102bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = udisks2-nosystemd
pkgdesc = Disk Management Service, version 2
- pkgver = 2.9.0
+ pkgver = 2.9.1
pkgrel = 1
url = http://www.freedesktop.org/wiki/Software/udisks
arch = i686
@@ -22,17 +22,19 @@ pkgbase = udisks2-nosystemd
optdepends = ntfs-3g: NTFS filesystem management support
optdepends = dosfstools: VFAT filesystem management support
optdepends = libiscsi: iSCSI support
- provides = udisks2=2.9.0
+ provides = udisks2=2.9.1
conflicts = udisks2
conflicts = udisks2-eudev
replaces = udisks2
replaces = udisks2-eudev
options = !libtool
backup = etc/udisks2/udisks2.conf
- source = https://github.com/storaged-project/udisks/archive/udisks-2.9.0.tar.gz
+ source = https://github.com/storaged-project/udisks/archive/udisks-2.9.1.tar.gz
source = disable_logind_support.patch
- sha512sums = d3ee7dac016e03b7d4fc6e2c64450953fe22469d854b5e7232ad95b356b05930ddf2c8372a74280825e6fff693ab53294cb5c071e2d85b347703dd58289a605e
+ source = remove_check.patch
+ sha512sums = 91480378347a9898b45f3425462958b4f2fdead6970f29399eb5cecb488b0c0282cc3823879233e74c87570467e366016b785af772bdb42d271d89deef142c78
sha512sums = 22041d363bd7e7a6cc3a7c49c169800a0fad0bc5d3fba5f8663bcd26e2ea09ed78dbdd31ace26a9700863d565be6026b4d2259d5ebbf234ad8571ce2795588ad
+ sha512sums = e98ef1d34b690e776dfaa9b8a801a98bac395aad38db55933caa843f685471ce9ccfe63287507396925234d17768400d8c38d735f209e515c708f7515ea7ba4f
pkgname = udisks2-nosystemd
diff --git a/PKGBUILD b/PKGBUILD
index b382a4b3eb0c..bbc86c9d92cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=udisks2-nosystemd
-pkgver=2.9.0
+pkgver=2.9.1
pkgrel=1
pkgdesc="Disk Management Service, version 2"
arch=('i686' 'x86_64')
@@ -24,9 +24,11 @@ replaces=('udisks2' 'udisks2-eudev')
options=(!libtool)
backup=('etc/udisks2/udisks2.conf')
source=(https://github.com/storaged-project/udisks/archive/udisks-$pkgver.tar.gz
- disable_logind_support.patch)
-sha512sums=('d3ee7dac016e03b7d4fc6e2c64450953fe22469d854b5e7232ad95b356b05930ddf2c8372a74280825e6fff693ab53294cb5c071e2d85b347703dd58289a605e'
- '22041d363bd7e7a6cc3a7c49c169800a0fad0bc5d3fba5f8663bcd26e2ea09ed78dbdd31ace26a9700863d565be6026b4d2259d5ebbf234ad8571ce2795588ad')
+ disable_logind_support.patch
+ remove_check.patch)
+sha512sums=('91480378347a9898b45f3425462958b4f2fdead6970f29399eb5cecb488b0c0282cc3823879233e74c87570467e366016b785af772bdb42d271d89deef142c78'
+ '22041d363bd7e7a6cc3a7c49c169800a0fad0bc5d3fba5f8663bcd26e2ea09ed78dbdd31ace26a9700863d565be6026b4d2259d5ebbf234ad8571ce2795588ad'
+ 'e98ef1d34b690e776dfaa9b8a801a98bac395aad38db55933caa843f685471ce9ccfe63287507396925234d17768400d8c38d735f209e515c708f7515ea7ba4f')
prepare() {
cd "udisks-udisks-$pkgver"
@@ -36,6 +38,9 @@ prepare() {
# initsystem which supports tmpfiles.d configs.
patch -p1 -i "$srcdir"/disable_logind_support.patch
+ # Allow to build with ZRAM support but without systemd installed
+ patch -p1 -i "$srcdir"/remove_check.patch
+
NOCONFIGURE=1 ./autogen.sh
}
diff --git a/remove_check.patch b/remove_check.patch
new file mode 100644
index 000000000000..ff39df5cb8c3
--- /dev/null
+++ b/remove_check.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.ac b/configure.ac
+index b5f25905..b9a15afb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -463,11 +463,6 @@ if test "x$enable_zram" = "xyes" \
+ fi
+ fi
+
+- # needs systemd
+- if test -z "$systemdsystemunitdir"; then
+- AC_MSG_ERROR([systemd is required for ZRAM support])
+- fi
+-
+ have_zram="yes"
+
+ if test "$have_kbd" = "yes" -a "$have_swap" = "yes"; then