summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD16
3 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93113c6c3e2c..a878b09fc8e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = uefitool
pkgdesc = UEFI firmware image viewer and editor and utilities
pkgver = 0.28.0
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/LongSoft/UEFITool
arch = armv7h
@@ -11,6 +11,10 @@ pkgbase = uefitool
license = BSD
makedepends = zip
depends = qt5-base
+ provides = uefipatch
+ conflicts = uefitool-git
+ conflicts = uefipatch
+ replaces = uefipatch
source = UEFITool-0.28.0.tar.gz::https://github.com/LongSoft/UEFITool/archive/0.28.0.tar.gz
sha256sums = 453cc817e17cf9aa5c5306df1994828c4f6cf9180e67bede2bbaca1135b43d3c
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..934f0489f207
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.*
+src/
+pkg/
+*.pkg.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 184d1a472611..17f9d075cf9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=uefitool
_pkgname=UEFITool
_tools=(UEFIPatch UEFIReplace)
pkgver=0.28.0
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='UEFI firmware image viewer and editor and utilities'
arch=('armv7h' 'aarch64' 'i686' 'x86_64')
@@ -13,24 +13,24 @@ url='https://github.com/LongSoft/UEFITool'
license=('BSD')
depends=('qt5-base')
makedepends=('zip')
+provides=(uefipatch)
+conflicts=("${pkgname}-git" uefipatch)
+replaces=(uefipatch)
source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha256sums=('453cc817e17cf9aa5c5306df1994828c4f6cf9180e67bede2bbaca1135b43d3c')
build() {
cd "${_pkgname}-${pkgver}"
- ./unixbuild.sh --configure
-
- for _tool in "${_tools[@]}"; do
- cd "${_tool}"
- make
- cd ..
- done
+ ./unixbuild.sh
}
package() {
cd "${_pkgname}-${pkgver}"
+ local _tool="UEFITool"
+ install -Dm755 "${_tool}" "${pkgdir}/usr/bin/${_tool,,}"
+
for _tool in "${_tools[@]}"; do
install -Dm755 "${_tool}/${_tool}" "${pkgdir}/usr/bin/${_tool,,}"
done