summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.nvchecker.toml2
-rw-r--r--PKGBUILD37
3 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 193360803173..5027ca2954a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = ufostroker-git
pkgdesc = Add path effects to open glyphs in a UFO file
- pkgver = 0.0.0.r4.g20df06b
+ pkgver = 0.0.0.r8.g2fd58b2
pkgrel = 1
url = https://github.com/simoncozens/ufostroker
arch = x86_64
license = Apache
makedepends = cargo-nightly
+ makedepends = fontconfig
+ makedepends = freetype2
makedepends = git
- makedepends = rust-nightly
- source = ufostroker-git::git+https://github.com/simoncozens/ufostroker.git
+ source = git+https://github.com/simoncozens/ufostroker.git
sha256sums = SKIP
pkgname = ufostroker-git
-
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..2fe641ae158f
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,2 @@
+[ufostroker-git]
+source = 'manual'
diff --git a/PKGBUILD b/PKGBUILD
index 2ecb910807c6..7bf0fb1a5f6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,45 @@
# Maintainer: Caleb Maclennan <caleb@aleque.com>
pkgname=ufostroker-git
-pkgver=0.0.0.r4.g20df06b
+pkgver=0.0.0.r8.g2fd58b2
pkgrel=1
pkgdesc='Add path effects to open glyphs in a UFO file'
arch=(x86_64)
url="https://github.com/simoncozens/${pkgname%-git}"
license=(Apache)
-makedepends=(cargo-nightly git rust-nightly)
-source=("$pkgname::git+$url.git")
+makedepends=(cargo-nightly
+ fontconfig
+ freetype2
+ git)
+source=("git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git tag | grep -Fq '0.0.0' || git tag '0.0.0' d4a63044
- git describe --long --tags --abbrev=7 --match='[0-9]*' |
- sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname%-git}"
+ git tag | grep -Fq '0.0.0' || git tag '0.0.0' d4a63044
+ git describe --long --tags --abbrev=7 --match='[0-9]*' |
+ sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$pkgname"
- cargo +nightly fetch --locked
+ cd "${pkgname%-git}"
+ cargo fetch --locked --target x86_64-unknown-linux-gnu
}
build() {
- cd "$pkgname"
- cargo +nightly build --release --locked --all-features
+ cd "${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=nightly
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
}
check() {
- cd "$pkgname"
- cargo +nightly test --release --locked
+ cd "${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=nightly
+ cargo test --frozen --all-features
}
package() {
- cd "$pkgname"
- install -Dm755 -t "$pkgdir/usr/bin" "target/release/${pkgname%-git}"
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+ cd "${pkgname%-git}"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${pkgname%-git}"
}