summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec930f59cc9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Apr 22 03:42:45 UTC 2020
+pkgbase = ugrep-git
+ pkgdesc = Ultra fast interactive searcher of file systems, text and binary files, source code, archives, compressed files, documents, and more.
+ pkgver = 2.0.2.r1.gc47f5c5
+ pkgrel = 1
+ url = https://github.com/Genivia/ugrep
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = pcre2
+ depends = zlib
+ depends = bzip2
+ depends = xz
+ conflicts = ugrep
+ source = ugrep-git::git+https://github.com/Genivia/ugrep
+ md5sums = SKIP
+
+pkgname = ugrep-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24626a57142b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=ugrep-git
+pkgver=2.0.2.r1.gc47f5c5
+pkgrel=1
+pkgdesc="Ultra fast interactive searcher of file systems, text and binary files, source code, archives, compressed files, documents, and more."
+arch=('i686' 'x86_64')
+url="https://github.com/Genivia/ugrep"
+license=(BSD)
+depends=(pcre2 zlib bzip2 xz)
+makedepends=(git)
+conflicts=("${pkgname%-*}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./build.sh --prefix=${pkgdir}/usr/
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make install
+ install -D -m644 LICENSE.txt $pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE
+}