summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--adapt_mozc2.17.2240.102.patch28
3 files changed, 39 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dcac6ebaedf..621508c4174d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = uim-mozc
pkgdesc = uim plugin module for Mozc
- pkgver = 2.17.2123.102
+ pkgver = 2.17.2240.102
pkgrel = 1
url = http://code.google.com/p/macuim/
install = uim-mozc.install
@@ -15,10 +15,12 @@ pkgbase = uim-mozc
makedepends = clang
depends = mozc
depends = uim
- source = mozc::git+https://github.com/google/mozc.git#commit=e398317a086a78c0cf0004505eb8f56586e925b2
+ source = mozc::git+https://github.com/google/mozc.git#commit=95de40fa884d693172605e7283ec82233a908b29
source = http://downloads.sourceforge.net/project/pnsft-aur/mozc/uim-mozc-318.0562676.tar.xz
+ source = adapt_mozc2.17.2240.102.patch
sha1sums = SKIP
sha1sums = 5cd298aaac5afd7ff8882453e3e8fa698c2c5aa1
+ sha1sums = 031654d8fb40225a6c193d89246b294256ae33f4
pkgname = uim-mozc
diff --git a/PKGBUILD b/PKGBUILD
index 864c5854f438..275c3ba74e8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,11 +7,11 @@ _bldtype=Release
#_bldtype=Debug
_uimmozcrev=318.0562676
-_mozcrev=e398317a086a78c0cf0004505eb8f56586e925b2
+_mozcrev=95de40fa884d693172605e7283ec82233a908b29
pkgname=uim-mozc
_pkgname=mozc
-pkgver=2.17.2123.102
+pkgver=2.17.2240.102
pkgrel=1
pkgdesc="uim plugin module for Mozc"
arch=('i686' 'x86_64')
@@ -24,9 +24,11 @@ makedepends=('pkg-config' 'python2' 'git' 'ninja' 'clang')
source=(
mozc::git+https://github.com/google/mozc.git#commit=${_mozcrev}
http://downloads.sourceforge.net/project/pnsft-aur/mozc/uim-mozc-${_uimmozcrev}.tar.xz
+ adapt_mozc2.17.2240.102.patch
)
sha1sums=('SKIP'
- '5cd298aaac5afd7ff8882453e3e8fa698c2c5aa1')
+ '5cd298aaac5afd7ff8882453e3e8fa698c2c5aa1'
+ '031654d8fb40225a6c193d89246b294256ae33f4')
pkgver() {
@@ -51,6 +53,8 @@ prepare() {
# Extract license part of uim-mozc
head -n 32 unix/uim/mozc.cc > unix/uim/LICENSE
+ patch -p2 -i "${srcdir}/adapt_mozc2.17.2240.102.patch"
+
}
diff --git a/adapt_mozc2.17.2240.102.patch b/adapt_mozc2.17.2240.102.patch
new file mode 100644
index 000000000000..a2aca48a6ac4
--- /dev/null
+++ b/adapt_mozc2.17.2240.102.patch
@@ -0,0 +1,28 @@
+diff -uNr mozc.orig/src/unix/uim/mozc.cc mozc/src/unix/uim/mozc.cc
+--- mozc.orig/src/unix/uim/mozc.cc 2015-12-02 20:12:47.386430000 +0900
++++ mozc/src/unix/uim/mozc.cc 2015-12-02 20:14:46.780606804 +0900
+@@ -33,6 +33,7 @@
+
+ //#include <config.h>
+
++#include <cstddef>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -50,6 +51,7 @@
+
+ #include "base/port.h"
+ #include "base/util.h"
++#include "base/init_mozc.h"
+ #include "protocol/config.pb.h"
+ #include "protocol/commands.pb.h"
+ #include "client/client.h"
+@@ -1196,7 +1198,7 @@
+ argv[0] = (char *)name;
+ argv[1] = NULL;
+
+- InitGoogle((const char *)argv[0], &argc, (char ***)&argv, true);
++ mozc::InitMozc((const char *)argv[0], &argc, (char ***)&argv, true);
+ mozc::uim::install_keymap();
+ }
+