summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb94b4d78e6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = uki-script
+ pkgdesc = A simple bash script and pacman hook to create unified kernel images.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://www.github.com/emakman/unified-kernel-image-script
+ arch = any
+ license = CC0
+ makedepends = git
+ depends = bash
+ depends = coreutils
+ depends = binutils
+ depends = sbsigntools
+ depends = sed
+ source = uki-script::git+http://www.github.com/emakman/unified-kernel-image-script
+ md5sums = SKIP
+
+pkgname = uki-script
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c463ef622866
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Tamvana Makuluni <sw@makuluni.com>
+pkgname=uki-script
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A simple bash script and pacman hook to create unified kernel images."
+arch=('any')
+url="https://www.github.com/emakman/unified-kernel-image-script"
+license=('CC0')
+groups=()
+depends=('bash' 'coreutils' 'binutils' 'sbsigntools' 'sed')
+optdependes=('systemd: for default EFI stub and splash image')
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('uki-script::git+http://www.github.com/emakman/unified-kernel-image-script')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/uki-script"
+ awk -e'/# v/ {print substr($2,2)}' uki-script
+}
+
+package() {
+ cd "$srcdir/uki-script"
+ DESTDIR="$pkgdir/" ./install
+}