summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD41
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b92bfa7d25a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = ukwm
+ pkgdesc = UKUI Pencere Yƶneticisi
+ pkgver = v1.1.8+1+gaa7eb3a
+ pkgrel = 1
+ url = https://mate-desktop.org
+ arch = x86_64
+ groups = ukui
+ license = GPL
+ makedepends = intltool
+ makedepends = gobject-introspection
+ makedepends = git
+ depends = dconf
+ depends = gobject-introspection-runtime
+ depends = gsettings-desktop-schemas
+ depends = libcanberra
+ depends = startup-notification
+ depends = zenity
+ depends = libsm
+ depends = gnome-desktop
+ depends = upower
+ depends = libxkbcommon-x11
+ depends = ukui-settings-daemon
+ depends = libgudev
+ depends = libinput
+ depends = cogl
+ depends = clutter
+ depends = pipewire
+ source = git+https://github.com/ukui/ukwm.git
+ sha256sums = SKIP
+
+pkgname = ukwm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12302f1ee737
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Cihan Alkan <cihanalk@gmail.com>
+
+pkgname=ukwm
+pkgver=v1.1.8+1+gaa7eb3a
+pkgrel=1
+pkgdesc="UKUI Pencere Yƶneticisi"
+url="https://mate-desktop.org"
+arch=('x86_64')
+license=('GPL')
+depends=(dconf gobject-introspection-runtime gsettings-desktop-schemas libcanberra
+ startup-notification zenity libsm gnome-desktop upower libxkbcommon-x11
+ ukui-settings-daemon libgudev libinput cogl clutter pipewire)
+makedepends=(intltool gobject-introspection git)
+optdepends=()
+groups=('ukui')
+
+source=("git+https://github.com/ukui/ukwm.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+prepare() {
+ cd ${pkgname}
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd ${pkgname}
+./configure --prefix=/usr \
+--disable-static \
+--enable-gtk-doc \
+--enable-compile-warnings=minimum
+make
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+}