summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
-rw-r--r--UMLet.sh.diff27
3 files changed, 15 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 672f9e2030da..0a6ecc42459c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = umlet
pkgdesc = Free UML Tool for Fast UML Diagrams (stand-alone version)
- pkgver = 14.3.0
+ pkgver = 15.0.0
pkgrel = 1
url = https://www.umlet.com
arch = any
@@ -8,12 +8,11 @@ pkgbase = umlet
makedepends = unzip
makedepends = patch
depends = java-runtime
- source = http://www.umlet.com/umlet_14_3/umlet-standalone-14.3.0.zip
+ source = http://www.umlet.com/umlet_15_0/umlet-standalone-15.0.0.zip
source = umlet.desktop
source = UMLet.sh.diff
- md5sums = 1202a9f93780b2187bfcdf96f8984955
+ md5sums = 0d77cc21066a3f8fb7f05f671d818177
md5sums = 4efcfeea2f54b849bc86e3f1905449be
- md5sums = 8117f3f2bf7764d94c38ac8ca02ed279
+ md5sums = 6ff2efb31dd588eeebf57720fdd13267
pkgname = umlet
-
diff --git a/PKGBUILD b/PKGBUILD
index 70c8bae0d421..75d9019c28d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Gleidson Echeli <gleidson dot echeli at gmail dot com>
pkgname=umlet
-pkgver=14.3.0
-_pkgver=14_3
+pkgver=15.0.0
+_pkgver=15_0
pkgrel=1
pkgdesc="Free UML Tool for Fast UML Diagrams (stand-alone version)"
arch=('any')
@@ -15,9 +15,9 @@ makedepends=('unzip' 'patch')
source=("http://www.umlet.com/umlet_${_pkgver}/umlet-standalone-${pkgver}.zip"
'umlet.desktop'
'UMLet.sh.diff')
-md5sums=('1202a9f93780b2187bfcdf96f8984955'
+md5sums=('0d77cc21066a3f8fb7f05f671d818177'
'4efcfeea2f54b849bc86e3f1905449be'
- '8117f3f2bf7764d94c38ac8ca02ed279')
+ '6ff2efb31dd588eeebf57720fdd13267')
prepare() {
cd "$srcdir"/Umlet
diff --git a/UMLet.sh.diff b/UMLet.sh.diff
index 9c881a94789a..f6f00116e049 100644
--- a/UMLet.sh.diff
+++ b/UMLet.sh.diff
@@ -1,25 +1,12 @@
---- a/umlet.sh 2018-04-06 09:59:28.000000000 +0200
-+++ b/umlet.sh 2018-08-30 18:54:03.979319149 +0200
-@@ -13,11 +13,8 @@
- # UMLET_JAVA_OPTS (optional) additional Java start options (-X..., -D...)
- # UMLET_HOME (optional) program directory of UMLet
- # ---------------------------------------------------------------------------------
--#
--# If you want to put umlet.sh in your home bin directory ($HOME/bin/) to start it from anywhere with
--# $ umlet.sh myDiagram.uxf
--# you must export the UMLET_HOME environment variable with the full qualified path of the UMLet installation directory.
+--- a/umlet.sh 2022-04-30 10:47:45.706328639 +0200
++++ a/umlet.sh 2022-04-30 10:48:48.419563220 +0200
+@@ -17,7 +17,8 @@
+ # If you want to put umlet.sh in your home bin directory ($HOME/bin/) to start it from anywhere with
+ # $ umlet.sh myDiagram.uxf
+ # you must export the UMLET_HOME environment variable with the full qualified path of the UMLet installation directory.
-# export UMLET_HOME=/path/to/umlet
+
+export UMLET_HOME=/usr/share/umlet
_UMLET_HOME="$(cd $(dirname $0);pwd)"
-
-@@ -28,7 +25,7 @@
- fi
-
- # UMLET_HOME wins against deprecated programDir
--if [ ! -x "${UMLET_HOME}" ] ; then
-+if [ ! -z "${UMLET_HOME}" ] ; then
- _UMLET_HOME="${UMLET_HOME}"
- fi
-
+