summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df92715f25e4..d66df08b0ed9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Mar 24 02:18:42 UTC 2016
+# Thu Mar 24 02:26:28 UTC 2016
pkgbase = umlet
pkgdesc = Free UML Tool for Fast UML Diagrams
pkgver = 14.1.1
@@ -11,7 +11,6 @@ pkgbase = umlet
makedepends = maven
makedepends = unzip
depends = java-environment
- replaces = eclipse-umlet
source = umlet.sh
source = umlet.desktop
source = https://github.com/umlet/umlet/archive/2016-01-14_UMLet_v14.1.1.tar.gz
@@ -24,5 +23,6 @@ pkgname = umlet-standalone
pkgname = umlet-eclipse-plugin
pkgdesc = Free UML Tool for Fast UML Diagrams (Eclipse Plugin Version)
- optdepends = eclipse
+ depends = eclipse
+ replaces = eclipse-umlet
diff --git a/PKGBUILD b/PKGBUILD
index d8487bcea89d..4135a5bd9313 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,7 +26,7 @@ makedepends=('maven' 'unzip')
# Package Relations
#provides=()
#conflicts=()
-replaces=('eclipse-umlet')
+#replaces=()
# Others
#backup=()
@@ -76,7 +76,8 @@ package_umlet-standalone() {
package_umlet-eclipse-plugin() {
pkgdesc="${pkgdesc} (Eclipse Plugin Version)"
- optdepends=('eclipse')
+ depends=('eclipse')
+ replaces=('eclipse-umlet')
install -dm755 "$pkgdir/usr/share/eclipse/plugins"
install -Dm644 "$srcdir/umlet-${_date}_UMLet_v${pkgver}/umlet-eclipse-plugin/target/com.umlet.plugin-${pkgver}.jar" "$pkgdir/usr/share/eclipse/plugins"
}