summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD10
-rw-r--r--umview-svn.diff23
2 files changed, 28 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0caa8bfea988..30a7fe9868c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,6 +26,11 @@ pkgver() {
printf "r%s" "${ver//[[:alpha:]]}"
}
+prepare() {
+ cd $srcdir/xmview-os
+ patch -i ../../${pkgname}.diff Makefile.am
+}
+
build(){
cd "$srcdir/xmview-os"
autoreconf -i &> /dev/null
@@ -38,11 +43,6 @@ build(){
}
package() {
- #tar -xf data.tar.xz
- #mkdir -p ${pkgdir}/usr/share/man
- #cp -r usr/share/doc ${pkgdir}/usr/share
- #cp -r usr/share/man/man2 ${pkgdir}/usr/share/man
- #cp -r usr/share/man/man5 ${pkgdir}/usr/share/man
cd "$srcdir/xmview-os"
make install
if [ "$CARCH" == "x86_64" ]; then
diff --git a/umview-svn.diff b/umview-svn.diff
new file mode 100644
index 000000000000..a11642b0a204
--- /dev/null
+++ b/umview-svn.diff
@@ -0,0 +1,23 @@
+*** Makefile.am 2015-10-06 14:03:17.750805891 +0200
+--- changes 2015-10-06 14:11:47.140424485 +0200
+***************
+*** 4,21 ****
+
+ SUBDIRS = doc include um_lib um_cmd um_testmodule umdev umdev_testmodules umdevmbr umbinfmt xmview ummisc ummisc_modules um_viewfs umnet umnet_modules umfuse_modules
+
+- if ENABLE_UMDEVTAP
+- SUBDIRS += umdevtap
+- endif
+-
+- if ENABLE_UMFUSE
+- SUBDIRS += umfuse
+- endif
+-
+- if ENABLE_UM_LWIP
+- SUBDIRS += umnetlwipv6
+- endif
+-
+ tags:
+ ctags -R .
+
+--- 4,9 ----