summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
-rw-r--r--understand4
3 files changed, 16 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c184aec09aa..4a7c935d615d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = understand-bin
pkgdesc = Static analysis tool for maintaining, measuring & analyzing critical or large code bases.
- pkgver = 5.0.971
+ pkgver = 5.1.1000
pkgrel = 1
url = https://scitools.com/
- arch = i686
arch = x86_64
license = custom
depends = libx11
@@ -13,18 +12,12 @@ pkgbase = understand-bin
depends = libxext
depends = ncurses5-compat-libs
options = !strip
- source_i686 = http://builds.scitools.com/all_builds/b971/Understand/Understand-5.0.971-Linux-32bit.tgz
- source_i686 = understand.desktop
- source_i686 = understand
- md5sums_i686 = 8c6e6d7ed564734c9794db71834f9b7a
- md5sums_i686 = 86ea741c38198d7291d5126ef0cd17f8
- md5sums_i686 = 2927bc21f24ff8776a1c601379c9f19f
- source_x86_64 = http://builds.scitools.com/all_builds/b971/Understand/Understand-5.0.971-Linux-64bit.tgz
- source_x86_64 = understand.desktop
- source_x86_64 = understand
- md5sums_x86_64 = ebd9bc489dbb84dfa35ace09dc09a68b
- md5sums_x86_64 = 86ea741c38198d7291d5126ef0cd17f8
- md5sums_x86_64 = 2927bc21f24ff8776a1c601379c9f19f
+ source = http://builds.scitools.com/all_builds/b1000/Understand/Understand-5.1.1000-Linux-64bit.tgz
+ source = understand.desktop
+ source = understand
+ md5sums = b6975de562aa22e7e770e62c149a3570
+ md5sums = 86ea741c38198d7291d5126ef0cd17f8
+ md5sums = bfcb2a7b5550e446939bae3e1a1165a8
pkgname = understand-bin
diff --git a/PKGBUILD b/PKGBUILD
index d077d18e51c2..ed7c8abd8e57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,43 +2,30 @@
_pkgname=understand
pkgname=$_pkgname-bin
-_pkgbuild=971
-pkgver=5.0.$_pkgbuild
+_pkgbuild=1000
+pkgver=5.1.$_pkgbuild
pkgrel=1
pkgdesc="Static analysis tool for maintaining, measuring & analyzing critical or large code bases."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://scitools.com/"
license=('custom')
depends=('libx11' 'libxau' 'libxcb' 'libxdmcp' 'libxext' 'ncurses5-compat-libs')
options=('!strip')
-source_i686=("http://builds.scitools.com/all_builds/b$_pkgbuild/${_pkgname^}/${_pkgname^}-$pkgver-Linux-32bit.tgz"
+source=("http://builds.scitools.com/all_builds/b$_pkgbuild/${_pkgname^}/${_pkgname^}-$pkgver-Linux-64bit.tgz"
"$_pkgname.desktop"
"$_pkgname")
-
-source_x86_64=("http://builds.scitools.com/all_builds/b$_pkgbuild/${_pkgname^}/${_pkgname^}-$pkgver-Linux-64bit.tgz"
-"$_pkgname.desktop"
-"$_pkgname")
-md5sums_i686=('8c6e6d7ed564734c9794db71834f9b7a'
- '86ea741c38198d7291d5126ef0cd17f8'
- '2927bc21f24ff8776a1c601379c9f19f')
-md5sums_x86_64=('ebd9bc489dbb84dfa35ace09dc09a68b'
+md5sums=('b6975de562aa22e7e770e62c149a3570'
'86ea741c38198d7291d5126ef0cd17f8'
- '2927bc21f24ff8776a1c601379c9f19f')
+ 'bfcb2a7b5550e446939bae3e1a1165a8')
package() {
- _source_arch="32"
- [ "$CARCH" = "x86_64" ] && _source_arch="64"
-
install -d "$pkgdir/opt"
cp -r "$srcdir/scitools" "$pkgdir/opt/"
- [ "$CARCH" = "x86_64" ] && sed -i s/linux32/linux64/ understand
install -Dm755 "$srcdir/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
install -Dm644 "$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
- install -Dm644 "$pkgdir/opt/scitools/bin/linux$_source_arch/${_pkgname}_64.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
-
- # install -Dm644 "$pkgdir/opt/scitools/conf/license/readme.txt" "$pkgdir/usr/share/licenses/$pkgname/readme.txt"
+ install -Dm644 "$pkgdir/opt/scitools/bin/linux64/${_pkgname}_64.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
}
diff --git a/understand b/understand
index e8922bfab26e..e6420661271a 100644
--- a/understand
+++ b/understand
@@ -1,4 +1,4 @@
#!/bin/bash
-export LD_LIBRARY_PATH=/opt/scitools/bin/linux32
+export LD_LIBRARY_PATH=/opt/scitools/bin/linux64
unset QT_PLUGIN_PATH
-/opt/scitools/bin/linux32/understand.bin "$@"
+LD_PRELOAD=/usr/lib/libfreetype.so.6 /opt/scitools/bin/linux64/understand "$@"