summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--unepic-hib.sh3
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90eb9bce8675
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = unepic-hib
+ pkgdesc = A combination of platforming and role playing games with many hilarious references. It takes place in Harnakon, a huge medieval castle.
+ pkgver = 1.50.5
+ pkgrel = 1
+ url = http://www.unepicgame.com/en/game.html
+ arch = x86_64
+ arch = i686
+ license = custom: commercial
+ depends = sh
+ depends = sdl2_mixer
+ depends = libogg
+ depends = glew
+ source = hib://unepic-15005.run
+ source = unepic-hib.sh
+ sha256sums = 11866de3bfdcac950c5bc29b6b5ff807e64307afef0b7f642378ccfcf2a073c8
+ sha256sums = 2e045f5cf056a3498acaf2dd03811f38a5fc87b10ae55160c53f6634494109ad
+
+pkgname = unepic-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3069f0c89b28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=unepic-hib
+pkgver=1.50.5
+pkgrel=1
+pkgdesc='A combination of platforming and role playing games with many hilarious references. It takes place in Harnakon, a huge medieval castle.'
+url="http://www.unepicgame.com/en/game.html"
+license=('custom: commercial')
+arch=('x86_64' 'i686')
+depends=('sh' 'sdl2_mixer' 'libogg' 'glew')
+source=("hib://unepic-15005.run"
+ "$pkgname.sh")
+sha256sums=('11866de3bfdcac950c5bc29b6b5ff807e64307afef0b7f642378ccfcf2a073c8'
+ '2e045f5cf056a3498acaf2dd03811f38a5fc87b10ae55160c53f6634494109ad')
+PKGEXT=".pkg.tar"
+
+package() {
+ # data
+ for _f in data image sound voices/english voices/spanish; do
+ install -d "$pkgdir"/opt/unepic/$_f
+ install -m644 data/$_f/* "$pkgdir"/opt/unepic/$_f
+ done
+ install -m644 data/voices/text.txt "$pkgdir"/opt/unepic/voices
+ install -m644 data/unepic.png "$pkgdir"/opt/unepic
+
+ # binary
+ case $CARCH in
+ i686)
+ install -m755 data/unepic32 "$pkgdir"/opt/unepic/unepic;;
+ x86_64)
+ install -m755 data/unepic64 "$pkgdir"/opt/unepic/unepic;;
+ esac
+
+ # launcher
+ install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/unepic
+}
diff --git a/unepic-hib.sh b/unepic-hib.sh
new file mode 100644
index 000000000000..a370a039b08d
--- /dev/null
+++ b/unepic-hib.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd /opt/unepic && exec ./unepic "$@"