summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD42
3 files changed, 31 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 263ec7cc3b22..520eb4a723de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = unflac
pkgdesc = A command line tool for fast frame accurate audio image + cue sheet splitting.
- pkgver = r58.d677c2e
+ pkgver = 1.0
pkgrel = 1
url = https://git.sr.ht/~ft/unflac
arch = x86_64
- license = unknown
+ license = MIT
makedepends = go
- makedepends = git
depends = ffmpeg
- source = git+https://git.sr.ht/~ft/unflac
- sha256sums = SKIP
+ source = https://git.sr.ht/~ft/unflac/archive/1.0.tar.gz
+ sha256sums = a09c54d04127707c3f556836590de5d2ae6a78bf17a99472b602ef983f89b7b4
pkgname = unflac
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1ba38eed2ea4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*tar* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 3cf274d41710..bf540466529f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,37 @@
-# Maintainer: droserasprout <droserasprout@tuta.io>
+# Maintainer: Lev Gorodetskiy <aur@drsr.io>
pkgname=unflac
pkgrel=1
-pkgver=r58.d677c2e
+pkgver=1.0
pkgdesc='A command line tool for fast frame accurate audio image + cue sheet splitting.'
arch=('x86_64')
url="https://git.sr.ht/~ft/$pkgname"
-license=('unknown')
-makedepends=('go' 'git')
+license=('MIT')
+makedepends=('go')
+source=("$url/archive/$pkgver.tar.gz")
depends=('ffmpeg')
-source=('git+https://git.sr.ht/~ft/unflac')
-sha256sums=('SKIP')
+sha256sums=('a09c54d04127707c3f556836590de5d2ae6a78bf17a99472b602ef983f89b7b4')
-pkgver() {
- cd "$pkgname"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
}
build() {
- cd $pkgname
- go get -u
- go build
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build .
}
-package() {
- cd $pkgname
- install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+check() {
+ cd "$pkgname-$pkgver"
+ go test ./...
}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+} \ No newline at end of file