summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD143
2 files changed, 37 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25d3c216797c..ebf3482cc860 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ungoogled-chromium-xdg-bin
pkgdesc = A lightweight approach to removing Google web service dependency - without creating a useless ~/.pki directory (binary version)
- pkgver = 106.0.5249.119
- pkgrel = 3
+ pkgver = 107.0.5304.88
+ pkgrel = 1
url = https://github.com/Eloston/ungoogled-chromium
arch = x86_64
license = BSD
@@ -18,6 +18,7 @@ pkgbase = ungoogled-chromium-xdg-bin
depends = libpulse
depends = pciutils
depends = libva
+ depends = wayland
depends = desktop-file-utils
depends = hicolor-icon-theme
depends = fontconfig
@@ -48,9 +49,9 @@ pkgbase = ungoogled-chromium-xdg-bin
provides = chromium
conflicts = chromium
options = !lto
- source = https://github.com/noahvogt/ungoogled-chromium-xdg-aur/releases/download/106.0.5249.119-3/ungoogled-chromium-xdg-bin-106.0.5249.119-3.tar.gz
+ source = https://github.com/noahvogt/ungoogled-chromium-xdg-aur/releases/download/107.0.5304.88-1/ungoogled-chromium-xdg-107.0.5304.88-1-x86_64.pkg.tar.zst
source = index.html
- sha256sums = 23f5c95b65d997ab17d85f735f192a7f4229cdc6fdd233ae11e3f11f8feb34db
+ sha256sums = 2d6acb4fdcbbf14855c37174ccedcd209ccd5e75c601d57d82904d4fef755b83
sha256sums = a4cdd2b86f32d5302c2792be841ff40d982b19bb58a4e63df9d77f4c706b8665
pkgname = ungoogled-chromium-xdg-bin
diff --git a/PKGBUILD b/PKGBUILD
index e719e53c93c8..cbd6be6c76fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,24 @@
# Maintainer: Noah Vogt (noahvogt) <noah@noahvogt.com>
-# Maintainer: Seppia <seppia@seppio.fish>
-# Maintainer: JustKidding <jk@vin.ovh>
-
-# Based on aur/chromium-vaapi, with ungoogled-chromium patches
-
-# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
-# Contributor: Pierre Schmitz <pierre@archlinux.de>
-# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
-# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium-xdg-bin
-pkgver=106.0.5249.119
-pkgrel=3
-_launcher_ver=8
+pkgver=107.0.5304.88
+pkgrel=1
pkgdesc="A lightweight approach to removing Google web service dependency - without creating a useless ~/.pki directory (binary version)"
arch=('x86_64')
url="https://github.com/Eloston/ungoogled-chromium"
license=('BSD')
depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
- 'desktop-file-utils' 'hicolor-icon-theme')
+ 'wayland' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=()
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: support for storing passwords in KWallet on Plasma')
options=('!lto') # Chromium adds its own flags for ThinLTO
-source=(https://github.com/noahvogt/${pkgname%-*}-aur/releases/download/$pkgver-$pkgrel/$pkgname-$pkgver-$pkgrel.tar.gz
+source=(https://github.com/noahvogt/${pkgname%-*}-aur/releases/download/$pkgver-$pkgrel/${pkgname%-*}-$pkgver-$pkgrel-x86_64.pkg.tar.zst
index.html)
-sha256sums=('23f5c95b65d997ab17d85f735f192a7f4229cdc6fdd233ae11e3f11f8feb34db'
+sha256sums=('2d6acb4fdcbbf14855c37174ccedcd209ccd5e75c601d57d82904d4fef755b83'
'a4cdd2b86f32d5302c2792be841ff40d982b19bb58a4e63df9d77f4c706b8665')
provides=('chromium')
conflicts=('chromium')
@@ -36,107 +26,38 @@ conflicts=('chromium')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
declare -gA _system_libs=(
- [brotli]=brotli
- [dav1d]=dav1d
- [ffmpeg]=ffmpeg
- [flac]=flac
- [fontconfig]=fontconfig
- [freetype]=freetype2
- [harfbuzz-ng]=harfbuzz
- [icu]=icu
- [jsoncpp]=jsoncpp
- [libaom]=aom
- [libavif]=libavif
- [libdrm]=
- [libjpeg]=libjpeg
- [libpng]=libpng
- #[libvpx]=libvpx
- [libwebp]=libwebp
- [libxml]=libxml2
- [libxslt]=libxslt
- [opus]=opus
- [re2]=re2
- [snappy]=snappy
- [woff2]=woff2
- [zlib]=minizip
+ [brotli]=brotli
+ [dav1d]=dav1d
+ [ffmpeg]=ffmpeg
+ [flac]=flac
+ [fontconfig]=fontconfig
+ [freetype]=freetype2
+ [harfbuzz-ng]=harfbuzz
+ [icu]=icu
+ [jsoncpp]=jsoncpp
+ [libaom]=aom
+ [libavif]=libavif
+ [libdrm]=
+ [libjpeg]=libjpeg
+ [libpng]=libpng
+ #[libvpx]=libvpx
+ [libwebp]=libwebp
+ [libxml]=libxml2
+ [libxslt]=libxslt
+ [opus]=opus
+ [re2]=re2
+ [snappy]=snappy
+ [woff2]=woff2
+ [zlib]=minizip
)
_unwanted_bundled_libs=(
- $(printf "%s\n" ${!_system_libs[@]} | sed 's/^libjpeg$/&_turbo/')
+ $(printf "%s\n" ${!_system_libs[@]} | sed 's/^libjpeg$/&_turbo/')
)
depends+=(${_system_libs[@]})
package() {
- cd "$pkgname/chromium-launcher-$_launcher_ver"
- make PREFIX=/usr DESTDIR="$pkgdir" install
- install -Dm644 LICENSE \
- "$pkgdir/usr/share/licenses/chromium/LICENSE.launcher"
-
- cd "../src"
-
- install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
- install -D out/Release/chromedriver "$pkgdir/usr/bin/chromedriver"
- install -Dm4755 out/Release/chrome_sandbox "$pkgdir/usr/lib/chromium/chrome-sandbox"
-
- install -Dm644 ../chromium-drirc-disable-10bpc-color-configs.conf \
- "$pkgdir/usr/share/drirc.d/10-$pkgname.conf"
-
- install -Dm644 chrome/installer/linux/common/desktop.template \
- "$pkgdir/usr/share/applications/chromium.desktop"
- install -Dm644 chrome/app/resources/manpage.1.in \
- "$pkgdir/usr/share/man/man1/chromium.1"
- sed -i \
- -e 's/@@MENUNAME@@/Chromium/g' \
- -e 's/@@PACKAGE@@/chromium/g' \
- -e 's/@@USR_BIN_SYMLINK_NAME@@/chromium/g' \
- "$pkgdir/usr/share/applications/chromium.desktop" \
- "$pkgdir/usr/share/man/man1/chromium.1"
-
- install -Dm644 chrome/installer/linux/common/chromium-browser/chromium-browser.appdata.xml \
- "$pkgdir/usr/share/metainfo/chromium.appdata.xml"
- sed -ni \
- -e 's/chromium-browser\.desktop/chromium.desktop/' \
- -e '/<update_contact>/d' \
- -e '/<p>/N;/<p>\n.*\(We invite\|Chromium supports Vorbis\)/,/<\/p>/d' \
- -e '/^<?xml/,$p' \
- "$pkgdir/usr/share/metainfo/chromium.appdata.xml"
-
- local toplevel_files=(
- chrome_100_percent.pak
- chrome_200_percent.pak
- chrome_crashpad_handler
- resources.pak
- v8_context_snapshot.bin
+ cp -R "${srcdir}/usr/" "${pkgdir}/usr"
- # ANGLE
- libEGL.so
- libGLESv2.so
-
- # SwiftShader ICD
- libvk_swiftshader.so
- vk_swiftshader_icd.json
- )
-
- #if [[ -z ${_system_libs[icu]+set} ]]; then
- # toplevel_files+=(icudtl.dat)
- #fi
-
-echo "${toplevel_files[@]}"
-
- cp "${toplevel_files[@]/#/out/Release/}" "$pkgdir/usr/lib/chromium/"
- install -Dm644 -t "$pkgdir/usr/lib/chromium/locales" out/Release/locales/*.pak
-
- for size in 24 48 64 128 256; do
- install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
- "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
- done
-
- for size in 16 32; do
- install -Dm644 "chrome/app/theme/default_100_percent/chromium/product_logo_$size.png" \
- "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
- done
-
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
- install -Dm644 "$srcdir/index.html" "$pkgdir/usr/share/ungoogled-chromium/index.html"
+ chown root "$pkgdir/usr/lib/chromium/chrome-sandbox"
+ chmod 4755 "$pkgdir/usr/lib/chromium/chrome-sandbox"
}
-
-# vim:set ts=2 sw=2 et: