summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f06d83631d9..eaafc59b89f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,27 @@
pkgbase = unifi-video
pkgdesc = Centralized management system for Ubiquiti UniFi surveillance cameras.
- pkgver = 3.10.11
- pkgrel = 1
+ pkgver = 3.10.13
+ pkgrel = 2
url = https://www.ubnt.com/
install = unifi-video.install
arch = x86_64
license = custom
+ makedepends = zip
depends = mongodb
depends = java-runtime>=8
depends = java-jsvc
depends = lsb-release
+ depends = which
conflicts = unifi-video-beta
- source = unifi-video-3.10.11.deb::https://dl.ubnt.com/firmwares/ufv/v3.10.11/unifi-video.Ubuntu18.04_amd64.v3.10.11.deb
+ source = unifi-video-3.10.13.deb::https://dl.ubnt.com/firmwares/ufv/v3.10.13/unifi-video.Ubuntu18.04_amd64.v3.10.13.deb
source = unifi-video.service
source = unifi-video.sysusers
source = unifi-video.tmpfiles
source = unifi-video.patch
- sha256sums = 3ce57bfc8021bb62d330daa64e6d6b4a2221ec9afbfe138783175d53d6bd8363
+ sha256sums = 5838c616b0f83601563cd371a0c64eb0ccdaee6fc6b3237a95b94ac59c224745
sha256sums = 9df948b046347c25e7c83e4837284ef63d9f8d3f28daa20a6c36e203e3ebfdb3
sha256sums = 90fb2f826a70d3b7815cd6a2253c2af6754c17504be28ef92ee223bd02093730
sha256sums = 1ba38968cd5822b336bcffde0a150ea8c2358471abbcbde641de1ad9555bbff1
sha256sums = 9e04a0ffe891fbda0ae0f7a7f3edbcc59118dfc4bd4fea19c1b44954579a3952
pkgname = unifi-video
-
diff --git a/PKGBUILD b/PKGBUILD
index 1d9ba6ebcb3e..bf433a7687c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,21 @@
# Maintainer: Donald Webster (fryfrog@gmail.com)
+# Contributor: Torben Nehmer (torben+aur-unifi-video at nehmer dot net)
pkgname=unifi-video
-pkgver=3.10.11
-pkgrel=1
+pkgver=3.10.13
+pkgrel=2
pkgdesc="Centralized management system for Ubiquiti UniFi surveillance cameras."
arch=('x86_64')
url="https://www.ubnt.com/"
license=('custom')
-depends=('mongodb' 'java-runtime>=8' 'java-jsvc' 'lsb-release')
+makedepends=('zip')
+depends=(
+ 'mongodb'
+ 'java-runtime>=8'
+ 'java-jsvc'
+ 'lsb-release'
+ 'which'
+)
conflicts=('unifi-video-beta')
install=unifi-video.install
source=("${pkgname}-${pkgver}.deb::https://dl.ubnt.com/firmwares/ufv/v${pkgver}/${pkgname}.Ubuntu18.04_amd64.v${pkgver}.deb"
@@ -16,7 +24,7 @@ source=("${pkgname}-${pkgver}.deb::https://dl.ubnt.com/firmwares/ufv/v${pkgver}/
'unifi-video.tmpfiles'
'unifi-video.patch')
-sha256sums=('3ce57bfc8021bb62d330daa64e6d6b4a2221ec9afbfe138783175d53d6bd8363'
+sha256sums=('5838c616b0f83601563cd371a0c64eb0ccdaee6fc6b3237a95b94ac59c224745'
'9df948b046347c25e7c83e4837284ef63d9f8d3f28daa20a6c36e203e3ebfdb3'
'90fb2f826a70d3b7815cd6a2253c2af6754c17504be28ef92ee223bd02093730'
'1ba38968cd5822b336bcffde0a150ea8c2358471abbcbde641de1ad9555bbff1'
@@ -31,6 +39,11 @@ package() {
cd "${pkgdir}/usr/bin"
patch -N < "${srcdir}/unifi-video.patch"
+ # see also: https://logging.apache.org/log4j/2.x/security.html
+ echo "Fixing Log4j JNDI Lookup vulnerability by removing JndiLookup.class (CVE-2021-45046)"
+ cd "${pkgdir}/usr/lib/unifi-video/lib"
+ zip -v -q -d log4j-core-*.jar org/apache/logging/log4j/core/lookup/JndiLookup.class
+
install -D -m 644 "${srcdir}/unifi-video.service" "${pkgdir}/usr/lib/systemd/system/unifi-video.service"
install -D -m 644 "${srcdir}/unifi-video.sysusers" "${pkgdir}/usr/lib/sysusers.d/unifi-video.conf"
install -D -m 644 "${srcdir}/unifi-video.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/unifi-video.conf"