summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--server.xml.patch20
3 files changed, 31 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4bfa37da714..2bdb817bd26f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu May 4 05:05:12 UTC 2017
+# Thu May 4 05:20:28 UTC 2017
pkgbase = unifi-video
pkgdesc = Centralized management system for Ubiquiti UniFi Surveillance Cameras
pkgver = 3.6.3
@@ -17,10 +17,12 @@ pkgbase = unifi-video
source = unifi-video.service
source = unifi-video.sysusers
source = unifi-video.patch
+ source = server.xml.patch
sha256sums = 2e37248acf0ca15fb864ce71081c22b9ff323414163acc9039da5417c42d1cc9
sha256sums = 9df948b046347c25e7c83e4837284ef63d9f8d3f28daa20a6c36e203e3ebfdb3
sha256sums = 90fb2f826a70d3b7815cd6a2253c2af6754c17504be28ef92ee223bd02093730
sha256sums = 903c8def2668124570986f113fabf7ef03a1c94cde3a42dbf530ad6a19f139e7
+ sha256sums = 0636452a8e45a64f0adf108afbb5823921fb013b427eaf644d9bae0d97c27b93
pkgname = unifi-video
diff --git a/PKGBUILD b/PKGBUILD
index ef5db05e1d13..4fac67162c24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,14 @@ install=unifi-video.install
source=("http://dl.ubnt.com/firmwares/unifi-video/${pkgver}/unifi-video_${pkgver}~Ubuntu16.04_amd64.deb"
'unifi-video.service'
'unifi-video.sysusers'
- 'unifi-video.patch')
+ 'unifi-video.patch'
+ 'server.xml.patch')
sha256sums=('2e37248acf0ca15fb864ce71081c22b9ff323414163acc9039da5417c42d1cc9'
'9df948b046347c25e7c83e4837284ef63d9f8d3f28daa20a6c36e203e3ebfdb3'
'90fb2f826a70d3b7815cd6a2253c2af6754c17504be28ef92ee223bd02093730'
- '903c8def2668124570986f113fabf7ef03a1c94cde3a42dbf530ad6a19f139e7')
+ '903c8def2668124570986f113fabf7ef03a1c94cde3a42dbf530ad6a19f139e7'
+ '0636452a8e45a64f0adf108afbb5823921fb013b427eaf644d9bae0d97c27b93')
check() {
if ! [[ -x $( which java ) ]]; then
@@ -44,6 +46,10 @@ package() {
cd "${pkgdir}/usr/bin"
patch -N < "${srcdir}/unifi-video.patch"
+ msg2 "Patching off compression..."
+ cd "${pkgdir}/usr/lib/unifi-video/conf"
+ patch -N < "${srcdir}/server.xml.patch"
+
msg2 "Installing systemd files..."
install -D -m 644 "${srcdir}/unifi-video.service" "${pkgdir}/usr/lib/systemd/system/unifi-video.service"
install -D -m 644 "${srcdir}/unifi-video.sysusers" "${pkgdir}/usr/lib/sysusers.d/unifi-video.conf"
diff --git a/server.xml.patch b/server.xml.patch
new file mode 100644
index 000000000000..a0699f482184
--- /dev/null
+++ b/server.xml.patch
@@ -0,0 +1,20 @@
+--- server.xml.orig 2017-05-03 22:17:10.137773938 -0700
++++ server.xml 2017-05-03 22:17:27.228191619 -0700
+@@ -32,7 +32,7 @@
+ connectionTimeout="20000"
+ redirectPort="${app.https.port}"
+ enableLookups="false"
+- compression="on"
++ compression="off"
+ compressableMimeType="text/css,text/html,text/javascript,application/json"
+ socket.rxBufSize="65535"
+ socket.txBufSize="65535"
+@@ -47,7 +47,7 @@
+ protocol="org.apache.coyote.http11.Http11NioProtocol"
+ enableLookups="false"
+ disableUploadTimeout="true"
+- compression="on"
++ compression="off"
+ compressableMimeType="text/css,text/html,text/javascript,application/json"
+ scheme="https"
+ secure="true"