summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD65
2 files changed, 34 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a718c36cc3e6..227557d5fc40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,21 @@
pkgbase = unifont
- pkgdesc = A free bitmap font with wide Unicode support (PCF, PSF and hex versions)
- pkgver = 15.0.01
+ pkgdesc = GNU Unifont Glyphs
+ pkgver = 15.1.04
pkgrel = 1
- url = http://unifoundry.com/
+ url = https://unifoundry.com/unifont/index.html
arch = any
license = GPL2
license = custom:OFL
- source = http://unifoundry.com/pub/unifont/unifont-15.0.01/unifont-15.0.01.tar.gz
- source = http://unifoundry.com/pub/unifont/unifont-15.0.01/unifont-15.0.01.tar.gz.sig
+ source = https://ftp.gnu.org/gnu/unifont/unifont-15.1.04/unifont-15.1.04.pcf.gz
+ source = https://ftp.gnu.org/gnu/unifont/unifont-15.1.04/unifont-15.1.04.pcf.gz.sig
+ source = https://ftp.gnu.org/gnu/unifont/unifont-15.1.04/Unifont-APL8x16-15.1.04.psf.gz
+ source = https://ftp.gnu.org/gnu/unifont/unifont-15.1.04/Unifont-APL8x16-15.1.04.psf.gz.sig
+ source = https://unifoundry.com/LICENSE.txt
validpgpkeys = 95D2E9AB8740D8046387FD151A09227B1F435A33
- sha256sums = 7d11a924bf3c63ea7fdf2da2b96d6d4986435bedfd1e6816c8ac2e6db47634d5
+ sha256sums = 5c728ff31c7e1af8456015b4dd26a66e977681c94abd0533d490232256f9f4e2
sha256sums = SKIP
+ sha256sums = f6845bb729ac22845398925b93932469b32a25cf9450c071683808b7b8db6fd6
+ sha256sums = SKIP
+ sha256sums = 1e74cb82bf476843e97c2596297b04219b1a7e51f7238944a8c031cb9401fa87
-pkgname = pcf-unifont
- pkgdesc = A free bitmap font with wide Unicode support (PCF version)
-
-pkgname = psf-unifont
- pkgdesc = A free bitmap font with wide Unicode support (PSF version)
-
-pkgname = hex-unifont
- pkgdesc = A free bitmap font with wide Unicode support (hex version)
-
-pkgname = unifont-utils
- pkgdesc = A free bitmap font with wide Unicode support - utilities
- arch = x86_64
- depends = perl
- optdepends = perl-wx: for the unifont-viewer utility
- optdepends = perl-gd: for the unihex2png and unipng2hex utilities
+pkgname = unifont
diff --git a/PKGBUILD b/PKGBUILD
index 965eaaefa317..82d8bc982092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,34 @@
# Maintainer: neeshy <neeshy@tfwno.gf>
-# Contributor: felix <`(( $RANDOM % 6 == 0 )) && base64 -d <<< ZmVsaXgudm9uLnNAcG9zdGVvLmRlCg== || sudo rm -rf /* `>
-pkgname=('pcf-unifont'
- 'psf-unifont'
- 'hex-unifont'
- 'unifont-utils')
-pkgbase=unifont
-pkgver=15.0.01
+# Contributor: felix <`base64 -d <<< ZmVsaXgudm9uLnNAcG9zdGVvLmRlCg==`>
+#pkgname=(pcf-unifont
+# psf-unifont)
+pkgname=unifont
+pkgver=15.1.04
pkgrel=1
-pkgdesc="A free bitmap font with wide Unicode support (PCF, PSF and hex versions)"
+pkgdesc="GNU Unifont Glyphs"
arch=('any')
-url="http://unifoundry.com/"
+url="https://unifoundry.com/unifont/index.html"
license=('GPL2' 'custom:OFL')
-source=("http://unifoundry.com/pub/unifont/unifont-$pkgver/unifont-$pkgver.tar.gz"{,.sig})
-sha256sums=('7d11a924bf3c63ea7fdf2da2b96d6d4986435bedfd1e6816c8ac2e6db47634d5'
- 'SKIP')
+source=("https://ftp.gnu.org/gnu/unifont/unifont-$pkgver/unifont-$pkgver.pcf.gz"{,.sig}
+ "https://ftp.gnu.org/gnu/unifont/unifont-$pkgver/Unifont-APL8x16-$pkgver.psf.gz"{,.sig}
+ "https://unifoundry.com/LICENSE.txt")
+sha256sums=('5c728ff31c7e1af8456015b4dd26a66e977681c94abd0533d490232256f9f4e2'
+ 'SKIP'
+ 'f6845bb729ac22845398925b93932469b32a25cf9450c071683808b7b8db6fd6'
+ 'SKIP'
+ '1e74cb82bf476843e97c2596297b04219b1a7e51f7238944a8c031cb9401fa87')
validpgpkeys=('95D2E9AB8740D8046387FD151A09227B1F435A33') # Paul Hardy <unifoundry@unifoundry.com>
-build() {
- cd "$srcdir/unifont-$pkgver/src"
- make
-}
-
package_pcf-unifont() {
- pkgdesc="A free bitmap font with wide Unicode support (PCF version)"
-
- cd "$srcdir/unifont-$pkgver/font/precompiled"
+ pkgdesc+=" (PCF version)"
+ cd "$srcdir"
install -Dm644 "unifont-$pkgver.pcf.gz" "$pkgdir/usr/share/fonts/misc/unifont.pcf.gz"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}
package_psf-unifont() {
- pkgdesc="A free bitmap font with wide Unicode support (PSF version)"
-
- cd "$srcdir/unifont-$pkgver/font/precompiled"
+ pkgdesc+=" (PSF version)"
+ cd "$srcdir"
install -Dm644 "Unifont-APL8x16-$pkgver.psf.gz" "$pkgdir/usr/share/kbd/consolefonts/Unifont-APL8x16.psf.gz"
-}
-
-package_hex-unifont() {
- pkgdesc="A free bitmap font with wide Unicode support (hex version)"
-
- cd "$srcdir/unifont-$pkgver/font/precompiled"
- install -Dm644 "unifont-$pkgver.hex" "$pkgdir/usr/share/unifont/unifont.hex"
-}
-
-package_unifont-utils() {
- pkgdesc="A free bitmap font with wide Unicode support - utilities"
- arch=('x86_64')
- depends=('perl')
- optdepends=(
- 'perl-wx: for the unifont-viewer utility'
- 'perl-gd: for the unihex2png and unipng2hex utilities'
- )
-
- cd "$srcdir/unifont-$pkgver"
- make -C src install PREFIX="$pkgdir/usr" LOCALBINDIR=../bin
- make -C man install PREFIX="$pkgdir/usr" COMPRESS=1
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}