aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5bea70329db5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = unilib
+ pkgdesc = unilib, the ANSI C support library
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/aquefir/unilib
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = slick>=1.1.0
+ provides = unilib
+ conflicts = unilib
+ source = https://github.com/aquefir/unilib/archive/v1.1.0-1.2.0.tar.gz
+ sha1sums = 14440199c1c8c7327d44d67e4016a59c12e62f1f
+
+pkgname = unilib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f07e90fccda6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Alexander Nicholi <me@nicholatian.com>
+pkgname=unilib
+pkgver=1.2.0
+pkgrel=1
+epoch=
+pkgdesc='unilib, the ANSI C support library'
+arch=('i686' 'x86_64')
+url="https://github.com/aquefir/$pkgname"
+license=('BSD')
+depends=('slick>=1.1.0')
+provides=("$pkgname")
+conflicts=("$pkgname")
+_symver=1.1.0
+source=("https://github.com/aquefir/$pkgname/archive/v${_symver}-$pkgver.tar.gz")
+sha1sums=('14440199c1c8c7327d44d67e4016a59c12e62f1f')
+
+_subprojects='arr chkmath decl endian err futils himem log str'
+
+build() {
+ cd "$srcdir/$pkgname-${_symver}-$pkgver"
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ make -j$(($(nproc) * 2))
+ cd ..
+ done
+}
+
+package() {
+ cd "$srcdir/$pkgname-${_symver}-$pkgver"
+
+ for _subproj in ${_subprojects}; do
+ cd "${_subproj}"
+ make install PREFIX="${pkgdir}/usr"
+ cd ..
+ done
+}