summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
-rwxr-xr-xunity-editor-beta2
3 files changed, 32 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 436578638142..43dc41fb5593 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 1 09:59:07 UTC 2016
+# Wed Dec 14 17:39:24 UTC 2016
pkgbase = unity-editor-beta
pkgdesc = The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences.
- pkgver = 5.5.0b5+20160927
- pkgrel = 3
+ pkgver = 5.6.0b1+20161213
+ pkgrel = 1
url = https://unity3d.com/
arch = x86_64
license = custom
@@ -25,8 +25,18 @@ pkgbase = unity-editor-beta
optdepends = java-environment: for Android and Tizen exporting
optdepends = android-sdk: for Android Remote
optdepends = android-udev: for Android Remote
- noextract = unity-editor-installer-5.5.0b5+20160927.sh
+ noextract = unity-editor-installer.sh
options = !strip
+ source = http://beta.unity3d.com/download/2e25f7ab9f17/unity-editor-installer.sh
+ source = EULA
+ source = unity-editor-beta
+ source = monodevelop-unity-beta
+ source = unity-monodevelop-beta.png
+ sha256sums = 58c89d5a693f7801f13463c68fc0757b09b9581e48c50195ee30ea5ab9824879
+ sha256sums = ead9cd0828720d50a2fff92b87ac1bb763f1ac307e38698119d3ffe1969d546c
+ sha256sums = 63afa0050dae75d9e448054c5318dddc62682a2bff39920cd1c3219481fb3387
+ sha256sums = 336ffc3f63e622aa394e1022c15a58ce94865d7b6d9465cbcca4ce943285763a
+ sha256sums = 6769b7ad1c1a1b088f1e96934d909fffef95d6a6c757420699f0a6705ef70a51
pkgname = unity-editor-beta
diff --git a/PKGBUILD b/PKGBUILD
index bfab4958bb71..32394c02d338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,11 @@
# Contributor: Ace <a.mad.coder at gmail dot com>
pkgname=unity-editor-beta
-_version=5.5.0
-_build=b5
-_buildtag=20160927
+_version=5.6.0
+_build=b1
+_buildtag=20161213
pkgver=${_version}${_build}+${_buildtag}
-pkgrel=3
+pkgrel=1
pkgdesc="The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences."
arch=('x86_64')
url='https://unity3d.com/'
@@ -32,31 +32,21 @@ optdepends=('ffmpeg: for WebGL exporting'
'java-environment: for Android and Tizen exporting'
'android-sdk: for Android Remote'
'android-udev: for Android Remote')
-#source=("http://download.unity3d.com/download_unity/linux/unity-editor-installer-${pkgver}.sh"
- #'EULA'
- #'unity-editor-beta'
- #'monodevelop-unity-beta'
- #'unity-monodevelop-beta.png')
-noextract=("unity-editor-installer-${pkgver}.sh")
-#sha256sums=('dc0002f8f7b3f519bcc21af2e931d15a8b30214c0688ff8c5eee475640055d23'
- #'1145d6ea536582dd4fc281283617ec6e351acd7be6e02f704d47d595fba37934'
- #'a6183b216e30a472b9592059f64a3a6279a9d3e56c5c343c93713b03fa863c4c'
- #'336ffc3f63e622aa394e1022c15a58ce94865d7b6d9465cbcca4ce943285763a'
- #'6769b7ad1c1a1b088f1e96934d909fffef95d6a6c757420699f0a6705ef70a51')
+source=('http://beta.unity3d.com/download/2e25f7ab9f17/unity-editor-installer.sh'
+ 'EULA'
+ 'unity-editor-beta'
+ 'monodevelop-unity-beta'
+ 'unity-monodevelop-beta.png')
+noextract=('unity-editor-installer.sh')
+sha256sums=('58c89d5a693f7801f13463c68fc0757b09b9581e48c50195ee30ea5ab9824879'
+ 'ead9cd0828720d50a2fff92b87ac1bb763f1ac307e38698119d3ffe1969d546c'
+ '63afa0050dae75d9e448054c5318dddc62682a2bff39920cd1c3219481fb3387'
+ '336ffc3f63e622aa394e1022c15a58ce94865d7b6d9465cbcca4ce943285763a'
+ '6769b7ad1c1a1b088f1e96934d909fffef95d6a6c757420699f0a6705ef70a51')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
prepare() {
- echo "************************************************************"
- echo "*** ***"
- echo "*** RIGHT NOW THE STABLE RELEASE IS NEWER! ***"
- echo "*** ***"
- echo "*** Edit this if you *really* want an old beta =] ***"
- echo "*** otherwise go and install unity-editor ***"
- echo "************************************************************"
- return 1
-
-
if [ "$(df . -BG --output=avail | awk -F'[^0-9]*' 'FNR==2 {print $2;}')" -le "10" ]; then
warning "It seems that you have less than 10GB left. If you are using
an AUR-Helper or building on a small partition (like /tmp), you might
@@ -66,8 +56,8 @@ prepare() {
build() {
msg2 "Extracting archive ..."
- yes | fakeroot sh "unity-editor-installer-${pkgver}.sh" > /dev/null
- rm "unity-editor-installer-${pkgver}.sh"
+ yes | fakeroot sh unity-editor-installer.sh > /dev/null
+ rm unity-editor-installer.sh
}
package() {
diff --git a/unity-editor-beta b/unity-editor-beta
index 34c58d7265ff..49b02dcfdc0d 100755
--- a/unity-editor-beta
+++ b/unity-editor-beta
@@ -7,4 +7,4 @@ unset GTK_IM_MODULE
export PATH=/opt/UnityBeta/Editor:$PATH
mkdir -p ~/.local/share/unity3d/Packages
-exec /opt/UnityBeta/Editor/Unity "$@"
+exec /opt/UnityBeta/Editor/Unity -no-throttle-updates "$@"