summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa193248b892..a8dd27844937 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,12 +47,16 @@ options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
prepare() {
- warning "If you are using an AUR-Helper or building on a small partition (like /tmp),"
- warning "you might want to change the build-/cache-directory as this package is rather big"
+ if [ "$(df . -BG --output=avail | awk -F'[^0-9]*' 'FNR==2 {print $2;}')" -le "10" ]; then
+ warning "It seems that you have less than 10GB left.If you are using an AUR-Helper"
+ warning "or building on a small partition (like /tmp), you might want to change the"
+ warning "build-/cache-directory as this package is rather big"
+ fi
}
build() {
- yes | fakeroot sh "unity-editor-installer-${pkgver}.sh"
+ msg2 "Extracting archive ..."
+ yes | fakeroot sh "unity-editor-installer-${pkgver}.sh" > /dev/null
rm "unity-editor-installer-${pkgver}.sh"
}