summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD39
2 files changed, 11 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d2c808860ac..604d7cab9787 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = unity-editor-beta-doc
pkgdesc = Unity User Manual and Scripting API Reference.
- pkgver = 2018.2.0f1+20180709
+ pkgver = 2018.3.0b1+
pkgrel = 1
url = https://unity3d.com/
arch = x86_64
license = custom
- makedepends = gtk3
- makedepends = libsoup
- makedepends = libarchive
depends = unity-editor-beta
options = !strip
- source = http://beta.unity3d.com/download/db9a69dc5569/UnitySetup-2018.2.0f1
- sha1sums = 25f558636adc41bc8263dc4976fd9df86d1f9f6d
+ source = https://docs.unity3d.com/2018.3/Documentation/uploads/UnityDocumentation.zip
+ sha1sums = 89730f4d24a14667d7c6151e822a5644439c075d
pkgname = unity-editor-beta-doc
diff --git a/PKGBUILD b/PKGBUILD
index 1edc1adcb430..8a65966d3a15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,9 @@
# Maintainer: Oscar Morante <spacepluk at gmail dot com>
-_version=2018.2.0
-_build=f1
-_buildtag=20180709
-_randomstring=db9a69dc5569
+_version=2018.3.0
+_build=b1
+_randomstring=3f0ac31c6d6f
_prefix=/opt/UnityBeta
-_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
-#_keepsources=yes
pkgname=unity-editor-beta-doc
pkgver=${_version}${_build}+${_buildtag}
@@ -16,34 +13,14 @@ arch=('x86_64')
url='https://unity3d.com/'
license=('custom')
depends=('unity-editor-beta')
-makedepends=('gtk3' 'libsoup' 'libarchive')
-source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
-sha1sums=('25f558636adc41bc8263dc4976fd9df86d1f9f6d')
+source=("https://docs.unity3d.com/2018.3/Documentation/uploads/UnityDocumentation.zip")
+sha1sums=('89730f4d24a14667d7c6151e822a5644439c075d')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
-unity-setup() {
- ./UnitySetup-${_version}${_build} \
- --download-location="${startdir}" \
- --install-location="${pkgdir}${_prefix}" \
- --unattended $@
-}
-
-extract-component() {
- msg2 "Extracting $1..."
- yes | unity-setup --components=$1 > "/tmp/$1.log"
-}
-
-prepare() {
- chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
-}
-
package() {
- mkdir -p "${pkgdir}${_prefix}"
- extract-component Documentation
-
- if [ -z "${_keepsources}" ]; then
- rm "${startdir}/Documentation.pkg"
- fi
+ _dest="${pkgdir}${_prefix}/Editor/Data"
+ install -d "${_dest}"
+ mv "$(find "${srcdir}" -name Documentation)" "${_dest}"
}