summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD54
-rw-r--r--unity-editor-bin.install8
2 files changed, 31 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb0f29b9f36f..9ae4985eb1de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,12 +16,12 @@ license=('custom')
url="https://unity3d.com/"
depends=('desktop-file-utils' 'xdg-utils' 'gcc-multilib' 'libgl' 'glu' 'nss' 'libpng12' 'libxtst' 'libpqxx' 'monodevelop')
optdepends=('ffmpeg: for WebGL exporting'
- 'nodejs: for WebGL exporting'
- 'java-runtime: for WebGL exporting'
- 'gzip: for WebGL exporting'
- 'java-environment: for Android and Tizen exporting'
- 'android-sdk: for Android Remote'
- 'android-udev: for Android Remote')
+ 'nodejs: for WebGL exporting'
+ 'java-runtime: for WebGL exporting'
+ 'gzip: for WebGL exporting'
+ 'java-environment: for Android and Tizen exporting'
+ 'android-sdk: for Android Remote'
+ 'android-udev: for Android Remote')
provides=('unity-editor')
conflicts=('unity-editor')
options=(!strip)
@@ -30,25 +30,25 @@ source=("http://files.unity3d.com/levi/unity-editor-${pkgver}_amd64.deb")
md5sums=('5ef887483b737b0d20ca69ff4d368103')
package() {
- bsdtar xf data.tar.gz
-
- # Moving stuff in place
- mv usr "${pkgdir}"
- mv opt "${pkgdir}"
-
- # Setting permissions on chrome-sandbox - necessary to run the program
- chown root:root "${pkgdir}"/opt/Unity/Editor/chrome-sandbox
- chmod 4755 "${pkgdir}"/opt/Unity/Editor/chrome-sandbox
-
- # Linking executables (symlinking does not work!)
- mkdir -p "${pkgdir}"/usr/bin
- #ln -s /opt/Unity/Editor/Unity "${pkgdir}"/usr/bin/unity-editor
- #ln -s /opt/Unity/MonoDevelop/bin/monodevelop "${pkgdir}"/usr/bin/unity-monodevelop
- echo -e "#!/bin/sh\nexec /opt/Unity/Editor/Unity \"$@\"" > "${pkgdir}"/usr/bin/unity-editor
- echo -e "#!/bin/sh\n\n# This prevents the editor from crashing when opening projects on some systems\nunset GTK_IM_MODULE\n\nexec /opt/Unity/MonoDevelop/bin/monodevelop \"$@\"" > "${pkgdir}"/usr/bin/unity-monodevelop
- chmod 755 "${pkgdir}"/usr/bin/unity-editor "${pkgdir}"/usr/bin/unity-monodevelop
-
- # Refering to the online license
- mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
- echo "Please refer to https://unity3d.com/legal/eula for detailed license information." > "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ bsdtar xf data.tar.gz
+
+ # Moving stuff in place
+ mv usr "${pkgdir}"
+ mv opt "${pkgdir}"
+
+ # Setting permissions on chrome-sandbox - necessary to run the program
+ chown root:root "${pkgdir}"/opt/Unity/Editor/chrome-sandbox
+ chmod 4755 "${pkgdir}"/opt/Unity/Editor/chrome-sandbox
+
+ # Linking executables (symlinking does not work!)
+ mkdir -p "${pkgdir}"/usr/bin
+ #ln -s /opt/Unity/Editor/Unity "${pkgdir}"/usr/bin/unity-editor
+ #ln -s /opt/Unity/MonoDevelop/bin/monodevelop "${pkgdir}"/usr/bin/unity-monodevelop
+ echo -e "#!/bin/sh\nexec /opt/Unity/Editor/Unity \"$@\"" > "${pkgdir}"/usr/bin/unity-editor
+ echo -e "#!/bin/sh\n\n# This prevents the editor from crashing when opening projects on some systems\nunset GTK_IM_MODULE\n\nexec /opt/Unity/MonoDevelop/bin/monodevelop \"$@\"" > "${pkgdir}"/usr/bin/unity-monodevelop
+ chmod 755 "${pkgdir}"/usr/bin/unity-editor "${pkgdir}"/usr/bin/unity-monodevelop
+
+ # Refering to the online license
+ mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
+ echo "Please refer to https://unity3d.com/legal/eula for detailed license information." > "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}
diff --git a/unity-editor-bin.install b/unity-editor-bin.install
index 79aac8c9a068..5ebabc7015a4 100644
--- a/unity-editor-bin.install
+++ b/unity-editor-bin.install
@@ -1,9 +1,9 @@
_update() {
- echo -e "\e[34;1m==>\e[39;1m Updating desktop MIME database...\e[0m"
- update-desktop-database -q
+ echo -e "\e[34;1m==>\e[39;1m Updating desktop MIME database...\e[0m"
+ update-desktop-database -q
- echo -e "\e[34;1m==>\e[39;1m Updating icon cache...\e[0m"
- xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ echo -e "\e[34;1m==>\e[39;1m Updating icon cache...\e[0m"
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
}
post_install() {