summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD41
2 files changed, 12 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fcffa0d8997..eabf2984b526 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = unity-editor-ios
pkgdesc = Allows building your Unity projects for the iOS platform
- pkgver = 2018.2.5f1+20180828
+ pkgver = 2018.2.6f1
pkgrel = 1
url = https://unity3d.com/
arch = x86_64
license = custom
- makedepends = gtk2
- makedepends = libsoup
- makedepends = libarchive
depends = unity-editor
options = !strip
- source = http://beta.unity3d.com/download/88f43da96871/UnitySetup-2018.2.5f1
- sha1sums = 2f1d98a40a6662fb7f1f722b311350b506fb931f
+ source = https://download.unity3d.com/download_unity/c591d9a97a0b/LinuxEditorTargetInstaller/UnitySetup-iOS-Support-for-Editor-2018.2.6f1.tar.xz
+ sha1sums = 980870186d0d23f7e0c581fd4fca900fa9440190
pkgname = unity-editor-ios
diff --git a/PKGBUILD b/PKGBUILD
index e7c1f0978bf9..b748ccd888b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,26 @@
-# Maintainer: Oscar Morante <spacepluk at gmail dot com>
+# Maintainer: Oscar Morante <spacepluk@gmail.com>
-_version=2018.2.5
+_version=2018.2.6
_build=f1
-_buildtag=20180828
-_randomstring=88f43da96871
+_randomstring=c591d9a97a0b
_prefix=/opt/Unity
-_unitydownloads="http://beta.unity3d.com/download/${_randomstring}"
-#_keepdownloads=yes
pkgname=unity-editor-ios
-pkgver=${_version}${_build}+${_buildtag}
+pkgver=${_version}${_build}
pkgrel=1
pkgdesc="Allows building your Unity projects for the iOS platform"
arch=('x86_64')
url='https://unity3d.com/'
license=('custom')
depends=('unity-editor')
-makedepends=('gtk2' 'libsoup' 'libarchive')
-source=("${_unitydownloads}/UnitySetup-${_version}${_build}")
-sha1sums=('2f1d98a40a6662fb7f1f722b311350b506fb931f')
+source=("https://download.unity3d.com/download_unity/${_randomstring}/LinuxEditorTargetInstaller/UnitySetup-iOS-Support-for-Editor-${_version}${_build}.tar.xz")
+sha1sums=('980870186d0d23f7e0c581fd4fca900fa9440190')
options=(!strip)
PKGEXT='.pkg.tar' # Prevent compressing of the final package
-unity-setup() {
- ./UnitySetup-${_version}${_build} \
- --download-location="${startdir}" \
- --install-location="${pkgdir}${_prefix}" \
- --unattended $@
-}
-
-extract-component() {
- msg2 "Extracting $1..."
- yes | unity-setup --components=$1 > "/tmp/$1.log"
-}
-
-prepare() {
- chmod +x "${srcdir}/UnitySetup-${_version}${_build}"
-}
-
package() {
- mkdir -p "${pkgdir}${_prefix}"
- extract-component iOS
-
- if [ -z "${_keepdownloads}" ]; then
- rm "${startdir}/UnitySetup-iOS-Support-for-Editor-${_version}${_build}.tar.xz"
- fi
+ _dest="${pkgdir}${_prefix}/Editor/Data/PlaybackEngines"
+ install -d "${_dest}"
+ mv "${srcdir}/Editor/Data/PlaybackEngines/iOSSupport" "${_dest}"
}