summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 737e4576f024..4758be6c2cef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unityhub
pkgdesc = The Unity Hub is a standalone application that streamlines the way you find, download, and manage your Unity Projects and installations.
- pkgver = 3.6.1
+ pkgver = 3.8.0
pkgrel = 1
url = https://unity.com/
install = unityhub.install
@@ -15,9 +15,9 @@ pkgbase = unityhub
optdepends = libicu50: May fix issues related to empty compiler errors
optdepends = icu70: : May fix issues related to empty compiler errors
conflicts = unityhub-beta
- source = unityhub-3.6.1.deb::https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/unityhub-amd64-3.6.1.deb
+ source = unityhub-3.8.0.deb::https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/unityhub-amd64-3.8.0.deb
source = license.txt
- sha256sums = ae91fceda16f6d86a7b61c0fc3f4a596e387febb63ea8c1c55eb410f8f9325e5
+ sha256sums = 4e3b8eb05e0b16a406c788f98ff12bf7b30d8559bbdaa96f19866f039bee5ecf
sha256sums = f0eb3a4bb148bb7f426e4f5b97e891265ac487710cbcba9282518537c7b5d833
pkgname = unityhub
diff --git a/PKGBUILD b/PKGBUILD
index 49a8136a7cad..09a77414b900 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Marius Glo <marius@mgl.dev>
pkgname=unityhub
-pkgver=3.6.1
+pkgver=3.8.0
pkgrel=1
pkgdesc="The Unity Hub is a standalone application that streamlines the way you find, download, and manage your Unity Projects and installations."
url="https://unity.com/"
@@ -12,25 +12,27 @@ arch=('x86_64')
license=('custom')
depends=('nss' 'gtk3' 'cpio' 'openssl-1.1')
optdepends=(
- 'libappindicator-gtk3: The official deb says this an optional dependency'
- 'gconf: Required by Unity 2019.4 or older'
- 'libicu50: May fix issues related to empty compiler errors'
- 'icu70: : May fix issues related to empty compiler errors'
+ 'libappindicator-gtk3: The official deb says this an optional dependency'
+ 'gconf: Required by Unity 2019.4 or older'
+ 'libicu50: May fix issues related to empty compiler errors'
+ 'icu70: : May fix issues related to empty compiler errors'
)
source=(
- "$pkgname-$pkgver.deb::https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/unityhub-amd64-${pkgver}.deb"
- 'license.txt'
+ "$pkgname-$pkgver.deb::https://hub.unity3d.com/linux/repos/deb/pool/main/u/unity/unityhub_amd64/unityhub-amd64-${pkgver}.deb"
+ 'license.txt'
+)
+sha256sums=(
+ '4e3b8eb05e0b16a406c788f98ff12bf7b30d8559bbdaa96f19866f039bee5ecf'
+ 'f0eb3a4bb148bb7f426e4f5b97e891265ac487710cbcba9282518537c7b5d833'
)
-sha256sums=('ae91fceda16f6d86a7b61c0fc3f4a596e387febb63ea8c1c55eb410f8f9325e5'
- 'f0eb3a4bb148bb7f426e4f5b97e891265ac487710cbcba9282518537c7b5d833')
conflicts=('unityhub-beta')
OPTIONS=(!strip)
install='unityhub.install'
package() {
- tar -xf 'data.tar.bz2' -C "$pkgdir/"
- mkdir -p "$pkgdir/usr/bin"
- ln -sf '/opt/unityhub/unityhub' "$pkgdir/usr/bin/unityhub"
+ tar -xf 'data.tar.bz2' -C "$pkgdir/"
+ mkdir -p "$pkgdir/usr/bin"
+ ln -sf '/opt/unityhub/unityhub' "$pkgdir/usr/bin/unityhub"
- install -Dm644 "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ install -Dm644 "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
}